* gnu/packages/astronomy.scm (python-poliastro)
[native-inputs]: Remove python-pytest-mypy.
* gnu/packages/check.scm (python-pytest-perf)[native-inputs]: Remove
python-pytest-mypy.
* gnu/packages/python-web.scm (python-portend)[native-inputs]: Remove
python-pytest-mypy.
* gnu/packages/python-xyz.scm (python-importlib-resources,
python-jaraco-classes, python-jaraco-collections,
python-jaraco-context, python-jaraco-functools, python-jaraco-test,
python-path, python-pip-run, python-inflect, python-tempora,
python-portalocker)[native-inputs]: Remove python-pytest-mypy.
---
gnu/packages/astronomy.scm | 3 +--
gnu/packages/check.scm | 1 -
gnu/packages/python-web.scm | 1 -
gnu/packages/python-xyz.scm | 15 ++-------------
4 files changed, 3 insertions(+), 17 deletions(-)
@@ -4629,8 +4629,7 @@ (define-public python-poliastro
python-flit-core
python-pytest
python-pytest-doctestplus
- python-pytest-mpl
- python-pytest-mypy))
+ python-pytest-mpl))
(propagated-inputs
(list python-astropy
python-astroquery
@@ -3113,7 +3113,6 @@ (define-public python-pytest-perf
(list python-pytest
python-pytest-checkdocs
python-pytest-enabler
- python-pytest-mypy
python-setuptools
python-wheel))
(propagated-inputs
@@ -699,7 +699,6 @@ (define-public python-portend
(native-inputs (list python-pytest
python-pytest-checkdocs
python-pytest-enabler
- python-pytest-mypy
python-setuptools
python-wheel))
(home-page "https://github.com/jaraco/portend")
@@ -5657,7 +5657,6 @@ (define-public python-portalocker
"0lawjm736vs86wlnxc3qqh37l11z0yx81xq3dmrw33m86kaq2bh3"))))
(build-system pyproject-build-system)
(native-inputs (list python-pytest
- python-pytest-mypy
python-pytest-timeout
python-redis
python-setuptools
@@ -12746,7 +12745,6 @@ (define-public python-importlib-resources
(list python-pytest
python-pytest-checkdocs
python-pytest-enabler
- python-pytest-mypy
python-setuptools-57
python-setuptools-scm))
(propagated-inputs
@@ -12893,7 +12891,6 @@ (define-public python-jaraco-classes
(native-inputs
(list python-pytest
python-pytest-checkdocs
- python-pytest-mypy
python-setuptools
python-setuptools-scm
python-wheel))
@@ -12925,7 +12922,6 @@ (define-public python-jaraco-collections
(native-inputs (list python-pytest
python-pytest-checkdocs
python-pytest-enabler
- python-pytest-mypy
python-setuptools
python-wheel))
(home-page "https://github.com/jaraco/jaraco.collections")
@@ -12983,7 +12979,6 @@ (define-public python-jaraco-context
(native-inputs
(list python-pytest
python-pytest-checkdocs
- python-pytest-mypy
python-setuptools
python-setuptools-scm
python-wheel))
@@ -13015,7 +13010,6 @@ (define-public python-jaraco-functools
(list python-jaraco-classes
python-pytest
python-pytest-checkdocs
- python-pytest-mypy
python-setuptools
python-setuptools-scm
python-wheel))
@@ -13107,7 +13101,6 @@ (define-public python-jaraco-text
(native-inputs (list python-pytest
python-pytest-checkdocs
python-pytest-enabler
- python-pytest-mypy
python-setuptools
python-wheel))
(home-page "https://github.com/jaraco/jaraco.text")
@@ -17846,8 +17839,7 @@ (define-public python-path
python-pygments
python-pytest
python-pytest-checkdocs
- python-pytest-enabler
- python-pytest-mypy)))
+ python-pytest-enabler)))
(properties (alist-delete 'hidden?
(package-properties
python-path-bootstrap)))))
@@ -17949,8 +17941,7 @@ (define-public python-pip-run
python-pygments
python-pytest
python-pytest-checkdocs
- python-pytest-enabler
- python-pytest-mypy)))
+ python-pytest-enabler)))
(properties (alist-delete 'hidden? (package-properties
python-pip-run-bootstrap)))))
@@ -22555,7 +22546,6 @@ (define-public python-inflect
python-pytest
python-pytest-checkdocs
python-pytest-enabler
- python-pytest-mypy
;; For the version number
python-setuptools-scm
python-setuptools
@@ -27826,7 +27816,6 @@ (define-public python-tempora
python-pytest-checkdocs
python-pytest-enabler
python-pytest-freezegun
- python-pytest-mypy
python-setuptools-scm
python-types-freezegun
python-types-pytz