[bug#76421] gnu: mozjs: Update to 128.7.0.
Commit Message
* gnu/packages/gnuzilla.scm (mozjs): Update to 128.7.0.
[#:phases]<configure>: Set HOME.
<adjust-tests>: Update accordingly.
[native-inputs]: Add rust-cbindgen.
[inputs]: Use icu4c-73.
(mozjs-102): New variable.
(mozjs-91) [inputs]: Adjust accordingly.
* gnu/packages/gnome.scm (gjs) [propagated-inputs]: Keep using
mozjs-102.
Change-Id: I231144295f3567a091a9292b4dc4168e9c7d49f7
Co-Authored-By: Liliana Marie Prikler <liliana.prikler@gmail.com>
---
gnu/packages/gnome.scm | 2 +-
gnu/packages/gnuzilla.scm | 53 ++++++++++++++++++++++++++++++++++-----
2 files changed, 48 insertions(+), 7 deletions(-)
base-commit: 93551174af7a96d61f22f013ad1b9935106bf040
Comments
Please do not commit this patch.
It actually breaks the build of mozjs-102 on account of new file
deletions on v. 128.
I'll work on a version 2.
Discarded in favor of 7c6ebbd9e639074b97881d311d4975b8e5214371.
@@ -7864,7 +7864,7 @@ (define-public gjs
xorg-server-for-tests))
(propagated-inputs
;; These are all in the Requires.private field of gjs-1.0.pc.
- (list cairo gobject-introspection mozjs))
+ (list cairo gobject-introspection mozjs-102))
(inputs
(list gtk+ readline))
(synopsis "Javascript bindings for GNOME")
@@ -104,7 +104,7 @@ (define-module (gnu packages gnuzilla)
(define-public mozjs
(package
(name "mozjs")
- (version "102.2.0")
+ (version "128.7.0")
(source (origin
(method url-fetch)
;; TODO: Switch to IceCat source once available on ftp.gnu.org.
@@ -113,7 +113,7 @@ (define-public mozjs
version "esr.source.tar.xz"))
(sha256
(base32
- "1zwpgis7py1bf8p88pz3mpai6a02qrdb8ww2fa9kxxdl9b8r2k81"))))
+ "1xwl6z8ax3dw5hjb5lwpl5641rmlizmfqs3xg74cnczsvm7bz9z0"))))
(build-system gnu-build-system)
(arguments
(list
@@ -161,6 +161,8 @@ (define-public mozjs
;; but not the root directory either.
(mkdir "run-configure-from-here")
(chdir "run-configure-from-here")
+ ;; Configure script writes to $HOME.
+ (setenv "HOME" (getcwd))
(setenv "SHELL" (which "sh"))
(setenv "CONFIG_SHELL" (which "sh"))
(setenv "AUTOCONF" (which "autoconf"))
@@ -198,7 +200,29 @@ (define-public mozjs
;; FIXME: got "en-US-posix", expected "en-US-POSIX".
(delete-file "non262/Intl/available-locales-supported.js")
;; FIXME: got "en-US", expected "en-US-POSIX"
- (delete-file "non262/Intl/available-locales-resolved.js"))))
+ (delete-file "non262/Intl/available-locales-resolved.js")
+
+ ;;; Since 115:
+ ;; Mismatching array lengths
+ (delete-file "non262/Intl/supportedValuesOf-timeZones-canonical.js")
+ ;; FIXME: got "America/Santa_Isabel", expected "America/Tijuana":
+ ;; America/Santa_Isabel -> America/Tijuana
+ (delete-file "non262/Intl/DateTimeFormat/timeZone_backward_links.js")
+ ;; TODO: tzdata 2024a expected – find a way to regenerate
+ ;; these generated tests
+ (delete-file "non262/Intl/DateTimeFormat/timeZone_version.js")
+
+ ;; FIXME: got "\uD840\uDDF2", expected "\u5047"
+ (delete-file "non262/Intl/Collator/implicithan.js")
+ ;; FIXME: got "\uD840\uDDF2", expected "\u3467"
+ (delete-file "non262/Intl/Collator/big5han-gb2312han.js")
+
+ ;; Since 128:
+ ;; FIXME: got (void 0), expected "GMT"
+ (delete-file "non262/Intl/DateTimeFormat/formatRange-timeZoneName-matches-format.js")
+ ;; FIXME: got 7, expected 9: parts count mismatch
+ (delete-file "non262/Intl/DateTimeFormat/formatRange-timeZone-offset.js")
+ (delete-file "non262/Intl/DateTimeFormat/formatRange-timeZoneName.js"))))
(add-before 'check 'pre-check
(lambda _
(setenv "JSTESTS_EXTRA_ARGS"
@@ -219,9 +243,10 @@ (define-public mozjs
pkg-config
python-wrapper
rust
- `(,rust "cargo")))
+ `(,rust "cargo")
+ rust-cbindgen))
(inputs
- (list icu4c readline zlib))
+ (list icu4c-73 readline zlib))
(propagated-inputs
(list nspr)) ; in the Requires.private field of mozjs-*.pc
(home-page
@@ -231,6 +256,22 @@ (define-public mozjs
in C/C++.")
(license license:mpl2.0))) ; and others for some files
+(define-public mozjs-102
+ (package
+ (inherit mozjs)
+ (name "mozjs")
+ (version "102.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ftp.mozilla.org/pub/firefox"
+ "/releases/" version "esr/source/firefox-"
+ version "esr.source.tar.xz"))
+ (sha256
+ (base32
+ "1zwpgis7py1bf8p88pz3mpai6a02qrdb8ww2fa9kxxdl9b8r2k81"))))
+ (inputs (modify-inputs (package-inputs mozjs)
+ (replace "icu4c-73" icu4c)))))
+
(define-public mozjs-91
(package
(inherit mozjs)
@@ -260,7 +301,7 @@ (define-public mozjs-91
(delete-file
"non262/Intl/DateTimeFormat/tz-environment-variable.js"))))))))
(inputs (modify-inputs (package-inputs mozjs)
- (replace "icu4c" icu4c-69)))))
+ (replace "icu4c-73" icu4c-69)))))
(define-public mozjs-78
(package