[bug#76416,python-team,2/2] gnu: python-multiprocess: Update to 0.70.17.

Message ID 20250219162351.27443-2-ngraves@ngraves.fr
State New
Headers
Series Minor updates |

Commit Message

Nicolas Graves Feb. 19, 2025, 4:23 p.m. UTC
  * gnu/packages/python-xyz.scm (python-multiprocess): Update to 0.70.17.
[arguments]{phases}: Use gexps. Remove phase
'disable-broken-tests. Improve phase 'check.
---
 gnu/packages/python-xyz.scm | 42 ++++++++++++++++++++-----------------
 1 file changed, 23 insertions(+), 19 deletions(-)
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b25140896a..f738b2b00c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29959,39 +29959,43 @@  (define-public python-dill
 (define-public python-multiprocess
   (package
     (name "python-multiprocess")
-    (version "0.70.14")
+    (version "0.70.17")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "multiprocess" version))
        (sha256
         (base32
-         "0splzd9w9yi42vl7b6mm99vb82jp2adhdrizw1xd4q125z0szp9y"))))
+         "0ypm9yj1ng1s96hk2iwll190dkpc2j5zras8kay9x00n6hdg3qja"))))
     (build-system pyproject-build-system)
     (arguments
      (list
       #:phases
-      '(modify-phases %standard-phases
-         (add-after 'unpack 'disable-broken-tests
-           (lambda _
-             ;; The "wait_result" and "shared_memory..." tests are broken as
-             ;; there is no keyboard interrupt.
-             ;;
-             ;; The "preload_resources" test fails as it cannot find
-             ;; mp_preload.py.
-             (substitute* "py3.10/multiprocess/tests/__init__.py"
-               (("^(.*)def test_(\
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'disable-broken-tests
+            (lambda* (#:key inputs #:allow-other-keys)
+              ;; The "wait_result" and "shared_memory..." tests are broken as
+              ;; there is no keyboard interrupt.
+              ;;
+              ;; The "preload_resources" test fails as it cannot find
+              ;; mp_preload.py.
+              (substitute*
+                  (string-append "py" (python-version
+                                       (assoc-ref inputs "python"))
+                                 "/multiprocess/tests/__init__.py")
+                (("^(.*)def test_(\
 wait_result|\
 shared_memory_SharedMemoryServer_ignores_sigint|\
 preload_resources\
 )" line indent)
-                (string-append indent
-                               "@unittest.skip(\"Disabled by Guix\")\n"
-                               line)))))
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "python" "-m" "multiprocess.tests")))))))
+                 (string-append indent
+                                "@unittest.skip(\"Disabled by Guix\")\n"
+                                line)))))
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (if tests?
+                  (invoke "python" "-m" "multiprocess.tests")
+                  (format #t "test suite not run~%")))))))
     (propagated-inputs
      (list python-dill))
     (native-inputs (list python-setuptools python-wheel))