[bug#76416,python-team,1/2] gnu: python-dill: Update to 0.3.9.
Commit Message
* gnu/packages/python-xyz.scm (python-dill): Update to 0.3.9.
[arguments]{phases}: Rewrite using gexp. Adapt 'check phase.
[native-inputs]: Remove python-nose.
---
gnu/packages/python-xyz.scm | 21 +++++++++++----------
1 file changed, 11 insertions(+), 10 deletions(-)
@@ -29924,24 +29924,25 @@ (define-public python-anndata
(define-public python-dill
(package
(name "python-dill")
- (version "0.3.6")
+ (version "0.3.9")
(source
(origin
(method url-fetch)
(uri (pypi-uri "dill" version))
(sha256
- (base32 "0wr37zwyiprrv29jcc1hl5cla72faiwfs0mhvbxxhmkqd3rmbnz5"))))
+ (base32 "0b2inivjahjlph54a70x6wi3pax4qsgclhlw0blbz37nvmyjdal1"))))
(build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (with-directory-excursion "/tmp"
- (invoke "nosetests" "-v"))))))))
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ ;; Extracted from tox.ini
+ (invoke "python" "dill/tests/__main__.py")
+ (format #t "test suite not run~%")))))))
(native-inputs
- (list python-nose python-setuptools python-wheel))
+ (list python-setuptools python-wheel))
(home-page "https://pypi.org/project/dill/")
(synopsis "Serialize all of Python")
(description "Dill extends Python's @code{pickle} module for serializing