[bug#76314,ruby-team,59/71] gnu: ruby-rubocop-rspec-minimal: Update to 2.26.0.

Message ID 20250216003503.6348-59-ngraves@ngraves.fr
State New
Headers
Series Update ruby. |

Commit Message

Nicolas Graves Feb. 16, 2025, 12:34 a.m. UTC
  * gnu/packages/ruby.scm (ruby-rubocop-rspec-minimal): Update to
2.26.0.
[propagated-inputs]: Add ruby-rubocop-factory-bot.
---
 gnu/packages/ruby.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)
  

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9293de713e..c1838add6b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2115,7 +2115,7 @@  enforcing & linting tool for @code{factory_bot} files.")
 (define ruby-rubocop-rspec-minimal
   (package
     (name "ruby-rubocop-rspec")
-    (version "2.19.0")
+    (version "2.26.0")
     (source
      (origin
        (method git-fetch)
@@ -2125,9 +2125,10 @@  enforcing & linting tool for @code{factory_bot} files.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0mgjyrzi8r44v3gb8xscdwspirz9kqkaf7zlsjhhlxr0di0rlj2r"))))
+         "1w9whadx60kv4vlbnk77b5yyhhfcg717r9cr334zqznqr1bqr8mh"))))
     (build-system ruby-build-system)
     (arguments (list #:tests? #f))      ;avoid extra dependencies
+    (propagated-inputs (list ruby-rubocop-factory-bot))
     (synopsis "Code style checking for RSpec files")
     (description "This package provides a plugin for the RuboCop code style
 enforcing & linting tool.")