[bug#76314,ruby-team,37/71] gnu: ruby-puma: Update to 6.5.0.

Message ID 20250216003503.6348-37-ngraves@ngraves.fr
State New
Headers
Series Update ruby. |

Commit Message

Nicolas Graves Feb. 16, 2025, 12:34 a.m. UTC
  * gnu/packages/ruby.scm (ruby-puma): Update to 6.5.0.
[native-inputs]: Add ruby-rackup-1.
[propagated-inputs]: Add ruby-concurrent-ruby.
---
 gnu/packages/ruby.scm | 13 ++++++++++---
 1 file changed, 10 insertions(+), 3 deletions(-)
  

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 11a85a825e..bb156da927 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12633,7 +12633,7 @@  part of the Prawn PDF generator.")
 (define-public ruby-puma
   (package
     (name "ruby-puma")
-    (version "6.3.0")
+    (version "6.5.0")
     (source
      (origin
        (method git-fetch)               ;for tests
@@ -12643,7 +12643,7 @@  part of the Prawn PDF generator.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0qnayzgyr23w87jc849r00394hv1gw2rk9080nws43ilnycagzxq"))))
+         "1z3njlmywins9yjl4a0c32vhkx9c4q4nia0snz7n45723jv96690"))))
     (build-system ruby-build-system)
     (arguments
      (list
@@ -12717,7 +12717,11 @@  part of the Prawn PDF generator.")
                             "test_culling_strategy_oldest_fork_worker"
                             "test_usr1_fork_worker")
                 (skip-tests "test/test_integration_pumactl.rb"
-                            "test_refork_cluster"))))
+                            "test_refork_cluster")
+                (skip-tests "test/test_web_concurrency_auto.rb" "\
+test_web_concurrency_with_concurrent_ruby_unavailable")
+                (skip-tests "test/helpers/integration.rb"
+                            "test_puma_started_log_writing"))))
           (add-before 'check 'relax-test-case-timeout
             (lambda _
               ;; The default value is 45 s and easily causes timeouts.
@@ -12744,11 +12748,14 @@  part of the Prawn PDF generator.")
            ruby-minitest-retry
            ruby-minitest-stub-const
            ruby-rack
+           ruby-rackup-1
            ruby-rake-compiler
            ruby-webrick))
     (inputs
      (list openssl
            ruby-nio4r))
+    (propagated-inputs
+     (list ruby-concurrent-ruby))
     (synopsis "Simple, concurrent HTTP server for Ruby/Rack")
     (description
      "Puma is a simple, fast, threaded, and highly concurrent HTTP 1.1 server