[bug#76273,v3,08/10] gnu: Add go-github-com-zyedidia-tcell.
Commit Message
* gnu/packages/golang-xyz.scm (go-github-com-zyedidia-tcell): New variable.
Change-Id: Id6d92347e6b7b080b906f5ef7849b6589fb80d04
---
gnu/packages/golang-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)
@@ -16097,6 +16097,39 @@ (define-public go-github-com-zyedidia-poller
cancels ongoing (blocked) read and write operations.")
(license license:bsd-2)))
+(define-public go-github-com-zyedidia-tcell
+ (package
+ (name "go-github-com-zyedidia-tcell")
+ (version "2.0.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zyedidia/tcell")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rbivmy79sc8hnygj7b3axhiqgbx6xc4f28pz69nhq9w2skk3zb9"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/zyedidia/tcell/v2"))
+ (propagated-inputs (list go-golang-org-x-text
+ go-golang-org-x-sys
+ go-github-com-zyedidia-poller
+ go-github-com-xo-terminfo
+ go-github-com-mattn-go-runewidth
+ go-github-com-lucasb-eyer-go-colorful
+ go-github-com-gdamore-encoding))
+ (home-page "https://github.com/zyedidia/tcell")
+ (synopsis
+ "Tcell is a Go package that provides a cell based view for text terminals")
+ (description
+ "Package tcell provides a lower-level, portable API for building programs that
+interact with terminals or consoles. It works with both common (and many
+uncommon!) terminals or terminal emulators, and Windows console implementations.")
+ (license license:asl2.0)))
+
(define-public go-go-abhg-dev-komplete
(package
(name "go-go-abhg-dev-komplete")