[bug#76273,v3,07/10] gnu: Add go-github-com-zyedidia-json5.
Commit Message
* gnu/packages/golang-xyz.scm (go-github-com-zyedidia-json5): New variable.
Change-Id: Ia931a9c4d86b4e42e45dcc72ffec58c7c3793efe
---
gnu/packages/golang-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
@@ -16041,6 +16041,30 @@ (define-public go-github-com-zyedidia-go-shellquote
word-splitting rules.")
(license license:expat)))
+(define-public go-github-com-zyedidia-json5
+ (package
+ (name "go-github-com-zyedidia-json5")
+ (version "0.0.0-20200102012142-2da050b1a98d")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zyedidia/json5")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1sgydazf3npr788b4w17ydmlh3fd1zmpriv9b69967ww90ckh2kz"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/zyedidia/json5"))
+ (home-page "https://github.com/zyedidia/json5")
+ (synopsis "Go JSON5 decoder package based on encoding/json")
+ (description
+ "This is a Go package that implements decoding of
+ @url{https://github.com/json5/json5, JSON5}.")
+ (license (list license:expat license:bsd-3))))
+
(define-public go-github-com-zyedidia-poller
(package
(name "go-github-com-zyedidia-poller")