[bug#76273,v2,06/10] gnu: Add go-github-com-zyedidia-go-shellquote.

Message ID 20250214185019.8937-8-ashvithshetty0010@zohomail.in
State New
Headers
Series gnu: Add micro. |

Commit Message

Ashvith Shetty Feb. 14, 2025, 6:50 p.m. UTC
  * gnu/packages/golang-xyz.scm (go-github-com-zyedidia-go-shellquote): New variable.

Change-Id: I39df8c180ac392cf1c89dd612921b09046c03189
---
 gnu/packages/golang-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
  

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index c678dd8048..9b93ba7819 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -16017,6 +16017,30 @@  (define-public go-github-com-zyedidia-go-runewidth
      "This package provides functions to get fixed width of the character or string.")
     (license license:expat)))
 
+(define-public go-github-com-zyedidia-go-shellquote
+  (package
+    (name "go-github-com-zyedidia-go-shellquote")
+    (version "0.0.0-20200613203517-eccd813c0655")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/zyedidia/go-shellquote")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0jxjj60kicpzc6i7vigg0i8iwnhf6jawcalq201a5wkxnkmdlw9g"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/kballard/go-shellquote"))
+    (home-page "https://github.com/zyedidia/go-shellquote")
+    (synopsis "Go utilities for performing shell-like word splitting/joining")
+    (description
+     "Shellquote provides utilities for joining/splitting strings using sh's
+word-splitting rules.")
+    (license license:expat)))
+
 (define-public go-github-com-zyedidia-poller
   (package
     (name "go-github-com-zyedidia-poller")