[bug#76273,v2,05/10] gnu: Add go-github-com-zyedidia-go-runewidth.
Commit Message
* gnu/packages/golang-xyz.scm (go-github-com-zyedidia-go-runewidth): New variable.
Change-Id: I17b2b97f25fffaa0e0cff9be9cc43d1f83412bb2
---
gnu/packages/golang-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
@@ -15993,6 +15993,30 @@ (define-public go-github-com-zyedidia-glob
"Package glob provides objects for matching strings with globs.")
(license license:expat)))
+(define-public go-github-com-zyedidia-go-runewidth
+ (package
+ (name "go-github-com-zyedidia-go-runewidth")
+ (version "0.0.12")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zyedidia/go-runewidth")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18gv5fkd69v8bwngj6r5zc572vyd1qhafz1wi3d7ynz3w0mmq85c"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/mattn/go-runewidth"))
+ (propagated-inputs (list go-github-com-rivo-uniseg))
+ (home-page "https://github.com/zyedidia/go-runewidth")
+ (synopsis "Provides wcwidth-like functionality for Go")
+ (description
+ "This package provides functions to get fixed width of the character or string.")
+ (license license:expat)))
+
(define-public go-github-com-zyedidia-poller
(package
(name "go-github-com-zyedidia-poller")