[bug#76273,v2,03/10] gnu: Add go-github-com-zyedidia-clipper.

Message ID 20250214185019.8937-5-ashvithshetty0010@zohomail.in
State New
Headers
Series gnu: Add micro. |

Commit Message

Ashvith Shetty Feb. 14, 2025, 6:50 p.m. UTC
  * gnu/packages/golang-xyz.scm (go-github-com-zyedidia-clipper): New variable.

Change-Id: Ib97afc64f6186034239b2c55454413d8033c1be1
---
 gnu/packages/golang-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
  

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 61ac06b5c8..dd968d4a58 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -15934,6 +15934,42 @@  (define-public go-github-com-zclconf-go-cty-debug
 utilities for cty Golang module.")
     (license license:expat)))
 
+(define-public go-github-com-zyedidia-clipper
+  (package
+    (name "go-github-com-zyedidia-clipper")
+    (version "0.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/zyedidia/clipper")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "18fv2cdll1d7d5wxs6r7kkhmk60pziiw3iy7knmdbcbhrk9rg112"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/zyedidia/clipper"))
+    (home-page "https://github.com/zyedidia/clipper")
+    (synopsis "@code{Clipper}: cross-platform clipboard library")
+    (description "Platforms supported:
+@itemize
+@item Linux (via xclip or xsel or wl-copy/wl-paste)
+@item MacOS (via pbcopy/pbpaste)
+@item Windows (via the Windows clipboard API)
+@item WSL (via clip.exe/powershell.exe)
+@item Android Termux (via termux-clipboard-set/termux-clipboard-get)
+@item Plan9 (via /dev/snarf)
+@item Anything else (via a user-defined script)
+@end itemize
+Fallback methods:
+@itemize
+@item Internal in-memory clipboard
+@item File-based clipboard
+@end itemize")
+    (license license:expat)))
+
 (define-public go-github-com-zyedidia-poller
   (package
     (name "go-github-com-zyedidia-poller")