[bug#76273,v1,09/10] gnu: Add go-github-com-zyedidia-json5.
Commit Message
From: Ashvith Shetty <ashvithshetty10@gmail.com>
* gnu/packages/golang-xyz.scm (go-github-com-zyedidia-json5): New variable.
Change-Id: I627ade8c26ec57a564ccde31dab20bd9fe5533ba
---
gnu/packages/golang-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
@@ -17849,6 +17849,28 @@ (define-public go-github-com-zyedidia-glob
"Package glob provides objects for matching strings with globs.")
(license license:expat)))
+(define-public go-github-com-zyedidia-json5
+ (package
+ (name "go-github-com-zyedidia-json5")
+ (version "0.0.0-20200102012142-2da050b1a98d")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zyedidia/json5")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1sgydazf3npr788b4w17ydmlh3fd1zmpriv9b69967ww90ckh2kz"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/zyedidia/json5"))
+ (home-page "https://github.com/zyedidia/json5")
+ (synopsis "Go JSON5 decoder package based on encoding/json")
+ (description "Package json5 implements decoding of JSON5 values.")
+ (license (list license:bsd-3 license:expat))))
+
(define-public go-github-com-zyedidia-terminal
(package
(name "go-github-com-zyedidia-terminal")