[bug#76273,v1,08/10] gnu: Add go-github-com-zyedidia-terminal.
Commit Message
From: Ashvith Shetty <ashvithshetty10@gmail.com>
* gnu/packages/golang-xyz.scm (go-github-com-zyedidia-terminal): New variable.
Change-Id: I05131f4d1c91aace4eed547dfa86d1b33e83bf45
---
gnu/packages/golang-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
@@ -17849,6 +17849,32 @@ (define-public go-github-com-zyedidia-glob
"Package glob provides objects for matching strings with globs.")
(license license:expat)))
+(define-public go-github-com-zyedidia-terminal
+ (package
+ (name "go-github-com-zyedidia-terminal")
+ (version "0.0.0-20230315200948-4b3bcf6dddef")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zyedidia/terminal")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0lqplkpllv63msf7sp8igrhvkrnr8l8hz4v5daliyn4qwvgs3k63"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/zyedidia/terminal"))
+ (propagated-inputs (list go-github-com-creack-pty))
+ (home-page "https://github.com/zyedidia/terminal")
+ (synopsis "Package terminal is a vt10x terminal emulation backend.")
+ (description
+ "Package terminal is a vt10x terminal emulation backend, influenced largely by
+@code{st}, @code{rxvt}, @code{xterm}, and @code{iTerm} as reference. Use it for terminal muxing, a
+terminal emulation frontend, or wherever else you need terminal emulation.")
+ (license license:expat)))
+
(define-public go-github-com-zyedidia-go-shellquote
(package
(name "go-github-com-zyedidia-go-shellquote")