[bug#76273,v1,07/10] gnu: Add go-github-com-zyedidia-go-shellquote.
Commit Message
From: Ashvith Shetty <ashvithshetty10@gmail.com>
* gnu/packages/golang-xyz.scm (go-github-com-zyedidia-go-shellquote): New variable.
Change-Id: Ib6f07b1bbd35d36598398de2e04baf25f0538a8f
---
gnu/packages/golang-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
@@ -17849,6 +17849,31 @@ (define-public go-github-com-zyedidia-glob
"Package glob provides objects for matching strings with globs.")
(license license:expat)))
+(define-public go-github-com-zyedidia-go-shellquote
+ (package
+ (name "go-github-com-zyedidia-go-shellquote")
+ (version "0.0.0-20200613203517-eccd813c0655")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zyedidia/go-shellquote")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jxjj60kicpzc6i7vigg0i8iwnhf6jawcalq201a5wkxnkmdlw9g"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/kballard/go-shellquote"
+ #:unpack-path "github.com/kballard/go-shellquote"))
+ (home-page "https://github.com/zyedidia/go-shellquote")
+ (synopsis "Go utilities for performing shell-like word splitting/joining")
+ (description
+ "Shellquote provides utilities for joining/splitting strings using sh's
+word-splitting rules.")
+ (license license:expat)))
+
(define-public go-github-com-zyedidia-go-runewidth
(package
(name "go-github-com-zyedidia-go-runewidth")