[bug#76273,v1,06/10] gnu: Add go-github-com-zyedidia-go-runewidth.

Message ID 20250214045910.4132-6-ashvithshetty0010@zohomail.in
State New
Headers
Series [bug#76273,v1,01/10] gnu: Add go-github-com-zyedidia-clipper. |

Commit Message

Ashvith Shetty Feb. 14, 2025, 4:59 a.m. UTC
  From: Ashvith Shetty <ashvithshetty10@gmail.com>

* gnu/packages/golang-xyz.scm (go-github-com-zyedidia-go-runewidth): New variable.

Change-Id: I1598551b5ed6aeaacbcc944b97d278810e4dfdd3
---
 gnu/packages/golang-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
  

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index c76233d06a..c6fa76c87c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -17849,6 +17849,31 @@  (define-public go-github-com-zyedidia-glob
      "Package glob provides objects for matching strings with globs.")
     (license license:expat)))
 
+(define-public go-github-com-zyedidia-go-runewidth
+  (package
+    (name "go-github-com-zyedidia-go-runewidth")
+    (version "0.0.12")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/zyedidia/go-runewidth")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "18gv5fkd69v8bwngj6r5zc572vyd1qhafz1wi3d7ynz3w0mmq85c"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/mattn/go-runewidth"
+      #:unpack-path "github.com/mattn/go-runewidth"))
+    (propagated-inputs (list go-github-com-rivo-uniseg))
+    (home-page "https://github.com/zyedidia/go-runewidth")
+    (synopsis "wcwidth for golang")
+    (description
+     "This package provides functions to get fixed width of the character or string.")
+    (license license:expat)))
+
 (define-public go-github-com-layeh-gopher-luar
   (package
     (name "go-github-com-layeh-gopher-luar")