[bug#76273,v1,05/10] gnu: Add go-github-com-layeh-gopher-luar.
Commit Message
From: Ashvith Shetty <ashvithshetty10@gmail.com>
* gnu/packages/golang-xyz.scm (go-github-com-layeh-gopher-luar): New variable.
Change-Id: Id7ab88f5d2b3db415fb06d201828c4012520e6b8
---
gnu/packages/golang-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
@@ -17849,6 +17849,30 @@ (define-public go-github-com-zyedidia-glob
"Package glob provides objects for matching strings with globs.")
(license license:expat)))
+(define-public go-github-com-layeh-gopher-luar
+ (package
+ (name "go-github-com-layeh-gopher-luar")
+ (version "1.0.11")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/layeh/gopher-luar")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zfafqy2jwjmrr0gl3h2ivn0iixb0bvslcwcly9bcmc5yxq35m89"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "layeh.com/gopher-luar"))
+ (propagated-inputs (list go-github-com-yuin-gopher-lua))
+ (home-page "https://github.com/layeh/gopher-luar")
+ (synopsis "Simplifies data passing to and from gopher-lua")
+ (description
+ "Package luar simplifies data passing to and from gopher-lua.")
+ (license license:mpl2.0)))
+
(define-public go-github-com-zyedidia-tcell-v2
(package
(name "go-github-com-zyedidia-tcell-v2")