[bug#76273,v1,04/10] gnu: Add go-github-com-zyedidia-tcell-v2.
Commit Message
From: Ashvith Shetty <ashvithshetty10@gmail.com>
* gnu/packages/golang-xyz.scm (go-github-com-zyedidia-tcell-v2): New variable.
Change-Id: I2b285c6cd06f86a5b072c1cf64e7937adc74d8b9
---
gnu/packages/golang-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)
@@ -17849,6 +17849,39 @@ (define-public go-github-com-zyedidia-glob
"Package glob provides objects for matching strings with globs.")
(license license:expat)))
+(define-public go-github-com-zyedidia-tcell-v2
+ (package
+ (name "go-github-com-zyedidia-tcell-v2")
+ (version "2.0.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zyedidia/tcell")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rbivmy79sc8hnygj7b3axhiqgbx6xc4f28pz69nhq9w2skk3zb9"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/zyedidia/tcell/v2"
+ #:unpack-path "github.com/zyedidia/tcell/v2"))
+ (propagated-inputs (list go-golang-org-x-text
+ go-golang-org-x-sys
+ go-github-com-zyedidia-poller
+ go-github-com-xo-terminfo
+ go-github-com-mattn-go-runewidth
+ go-github-com-lucasb-eyer-go-colorful
+ go-github-com-gdamore-encoding))
+ (home-page "https://github.com/zyedidia/tcell")
+ (synopsis "Tcell is an alternate terminal package, similar in some ways to termbox, but better in others.")
+ (description
+ "Package tcell provides a lower-level, portable API for building programs that
+interact with terminals or consoles. It works with both common (and many
+uncommon!) terminals or terminal emulators, and Windows console implementations.")
+ (license license:asl2.0)))
+
(define-public go-github-com-zyedidia-poller
(package
(name "go-github-com-zyedidia-poller")