[bug#76273,v1,01/10] gnu: Add go-github-com-zyedidia-clipper.
Commit Message
From: Ashvith Shetty <ashvithshetty10@gmail.com>
* gnu/packages/golang-xyz.scm (go-github-com-zyedidia-clipper): New variable.
Change-Id: Ia3eb2a28f5ef006b54e2698b3ebb66b75a05fb4f
---
gnu/packages/golang-xyz.scm | 38 +++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)
@@ -56,6 +56,7 @@
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2024 Roman Scherer <roman@burningswell.com>
+;;; Copyright © 2025 Ashvith Shetty <ashvithshetty0010@zohomail.in>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -17788,6 +17789,43 @@ (define-public misspell
#:import-path "github.com/client9/misspell/cmd/misspell"
#:unpack-path "github.com/client9/misspell"))))
+(define-public go-github-com-zyedidia-clipper
+ (package
+ (name "go-github-com-zyedidia-clipper")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zyedidia/clipper")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18fv2cdll1d7d5wxs6r7kkhmk60pziiw3iy7knmdbcbhrk9rg112"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/zyedidia/clipper"))
+ (home-page "https://github.com/zyedidia/clipper")
+ (synopsis "Clipper: cross-platform clipboard library")
+ (description
+ "Platforms supported:
+@itemize
+@item Linux (via xclip or xsel or wl-copy/wl-paste)
+@item MacOS (via pbcopy/pbpaste)
+@item Windows (via the Windows clipboard API)
+@item WSL (via clip.exe/powershell.exe)
+@item Android Termux (via termux-clipboard-set/termux-clipboard-get)
+@item Plan9 (via /dev/snarf)
+@item Anything else (via a user-defined script)
+@end itemize
+Fallback methods:
+@itemize
+@item Internal in-memory clipboard
+@item File-based clipboard
+@end itemize")
+ (license license:expat)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar