[bug#75995] gnu: freedoom: Update to 0.13.0.

Message ID 20250201175853.29342-1-ian@retrospec.tv
State New
Headers
Series [bug#75995] gnu: freedoom: Update to 0.13.0. |

Commit Message

Ian Eure Feb. 1, 2025, 5:58 p.m. UTC
  The update of python-pillow to 11.x broke this package, since its build
process used pillow features which were removed in that version.  This is
addressed in the 0.13.0 release, so, update to that.

* gnu/packages/games.scm (freedoom): Update to 0.13.0.

Change-Id: I0b9233e49bbfe13d395163b813c334c3b4c3ebb1
---
 gnu/packages/games.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
  

Comments

宋文武 Feb. 2, 2025, 6:37 a.m. UTC | #1
Ian Eure <ian@retrospec.tv> writes:

> The update of python-pillow to 11.x broke this package, since its build
> process used pillow features which were removed in that version.  This is
> addressed in the 0.13.0 release, so, update to that.
>
> * gnu/packages/games.scm (freedoom): Update to 0.13.0.

Pushed to master, thank you!
  

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0a2cc2f97f..0e5dc016a1 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1728,7 +1728,7 @@  (define-public foobillard++
 (define-public freedoom
   (package
     (name "freedoom")
-    (version "0.12.1")
+    (version "0.13.0")
     (source
      (origin
        (method git-fetch)
@@ -1737,7 +1737,7 @@  (define-public freedoom
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1mq60lfwaaxmch7hsz8403pwafnlsmsd5z2df2j77ppwndwcrypb"))))
+        (base32 "01fwzwi4a68n26d627dkcn85jz854mc3zfnzzkvinmx9yy3z5qmq"))))
     (build-system gnu-build-system)
     (arguments
      '(#:make-flags