[bug#75937,v3,37/90] gnu: ruby-puma: Update to 6.5.0.

Message ID 20250131065542.18548-38-ngraves@ngraves.fr
State New
Headers
Series Updating ruby |

Commit Message

Nicolas Graves Jan. 31, 2025, 6:53 a.m. UTC
  * gnu/packages/ruby.scm (ruby-puma): Update to 6.5.0.
[native-inputs]: Add ruby-rackup-1.
[propagated-inputs]: Add ruby-concurrent-ruby.
---
 gnu/packages/ruby.scm | 13 ++++++++++---
 1 file changed, 10 insertions(+), 3 deletions(-)
  

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 611b7ffc42..778bedf0c6 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12653,7 +12653,7 @@  (define-public ruby-ttfunk
 (define-public ruby-puma
   (package
     (name "ruby-puma")
-    (version "6.3.0")
+    (version "6.5.0")
     (source
      (origin
        (method git-fetch)               ;for tests
@@ -12663,7 +12663,7 @@  (define-public ruby-puma
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0qnayzgyr23w87jc849r00394hv1gw2rk9080nws43ilnycagzxq"))))
+         "1z3njlmywins9yjl4a0c32vhkx9c4q4nia0snz7n45723jv96690"))))
     (build-system ruby-build-system)
     (arguments
      (list
@@ -12737,7 +12737,11 @@  (define-public ruby-puma
                             "test_culling_strategy_oldest_fork_worker"
                             "test_usr1_fork_worker")
                 (skip-tests "test/test_integration_pumactl.rb"
-                            "test_refork_cluster"))))
+                            "test_refork_cluster")
+                (skip-tests "test/test_web_concurrency_auto.rb" "\
+test_web_concurrency_with_concurrent_ruby_unavailable")
+                (skip-tests "test/helpers/integration.rb"
+                            "test_puma_started_log_writing"))))
           (add-before 'check 'relax-test-case-timeout
             (lambda _
               ;; The default value is 45 s and easily causes timeouts.
@@ -12764,11 +12768,14 @@  (define-public ruby-puma
            ruby-minitest-retry
            ruby-minitest-stub-const
            ruby-rack
+           ruby-rackup-1
            ruby-rake-compiler
            ruby-webrick))
     (inputs
      (list openssl
            ruby-nio4r))
+    (propagated-inputs
+     (list ruby-concurrent-ruby))
     (synopsis "Simple, concurrent HTTP server for Ruby/Rack")
     (description
      "Puma is a simple, fast, threaded, and highly concurrent HTTP 1.1 server