* gnu/packages/check.scm (python-pytest-enabler, python-pytest-perf):
[native-inputs]: Remove python-pytest-flake8.
* gnu/packages/dav.scm (radicale)[native-inputs]: Remove
python-pytest-flake8.
* gnu/packages/python-check.scm (python-pytest-csv):
[arguments]<#:test-flags>: Ignore flake8 test.
[native-inputs]: Remove python-pytest-flake8.
* gnu/packages/python-web.scm (python-mechanicalsoup)[native-inputs]:
Remove python-pytest-flake8.
* gnu/packages/python-xyz.scm (python-importlib-resources,
python-jaraco-classes, python-jaraco-context, python-jaraco-functools,
python-jaraco-packaging, python-jaraco-test, python-path,
python-pip-run, python-tempora, python-cairosvg) [native-inputs]:
Remove python-pytest-flake8.
---
gnu/packages/check.scm | 2 --
gnu/packages/dav.scm | 1 -
gnu/packages/python-check.scm | 5 +++--
gnu/packages/python-web.scm | 3 +--
gnu/packages/python-xyz.scm | 12 +-----------
5 files changed, 5 insertions(+), 18 deletions(-)
@@ -2831,7 +2831,6 @@ (define-public python-pytest-enabler
python-toml))
(native-inputs (list python-pytest
python-pytest-checkdocs
- python-pytest-flake8
python-pytest-mypy
python-setuptools
python-setuptools-scm
@@ -3037,7 +3036,6 @@ (define-public python-pytest-perf
(list python-pytest
python-pytest-checkdocs
python-pytest-enabler
- python-pytest-flake8
python-pytest-mypy
python-setuptools
python-wheel))
@@ -58,7 +58,6 @@ (define-public radicale
(build-system pyproject-build-system)
(native-inputs
(list python-pytest
- python-pytest-flake8
python-setuptools
python-waitress
python-wheel))
@@ -651,9 +651,10 @@ (define-public python-pytest-csv
(base32
"17518f2fn5l98lyk9p8r7215c1whi61imzrh6ahrmcksr8w0zz04"))))
(build-system pyproject-build-system)
+ (arguments
+ (list #:test-flags '(list "--ignore=tests/test_flake8.py")))
(native-inputs
- (list python-pytest-flake8
- python-pytest-xdist
+ (list python-pytest-xdist
python-setuptools
python-tabulate
python-wheel))
@@ -2227,8 +2227,7 @@ (define-public python-mechanicalsoup
(propagated-inputs
(list python-beautifulsoup4 python-lxml python-requests python-six))
(native-inputs
- (list python-pytest-flake8
- python-pytest-httpbin
+ (list python-pytest-httpbin
python-pytest-mock
python-pytest-runner
python-requests-mock
@@ -12557,7 +12557,6 @@ (define-public python-importlib-resources
(list python-pytest
python-pytest-checkdocs
python-pytest-enabler
- python-pytest-flake8
python-pytest-mypy
python-setuptools-57
python-setuptools-scm))
@@ -12705,7 +12704,6 @@ (define-public python-jaraco-classes
(native-inputs
(list python-pytest
python-pytest-checkdocs
- python-pytest-flake8
python-pytest-mypy
python-setuptools
python-setuptools-scm
@@ -12796,7 +12794,6 @@ (define-public python-jaraco-context
(native-inputs
(list python-pytest
python-pytest-checkdocs
- python-pytest-flake8
python-pytest-mypy
python-setuptools
python-setuptools-scm
@@ -12829,7 +12826,6 @@ (define-public python-jaraco-functools
(list python-jaraco-classes
python-pytest
python-pytest-checkdocs
- python-pytest-flake8
python-pytest-mypy
python-setuptools
python-setuptools-scm
@@ -12859,7 +12855,6 @@ (define-public python-jaraco-packaging
(propagated-inputs
(list python-pytest
python-pytest-checkdocs
- python-pytest-flake8
python-rst.linker
python-setuptools
python-setuptools-scm
@@ -17728,7 +17723,6 @@ (define-public python-path
python-pytest
python-pytest-checkdocs
python-pytest-enabler
- python-pytest-flake8
python-pytest-mypy)))
(properties (alist-delete 'hidden?
(package-properties
@@ -17832,7 +17826,6 @@ (define-public python-pip-run
python-pytest
python-pytest-checkdocs
python-pytest-enabler
- python-pytest-flake8
python-pytest-mypy)))
(properties (alist-delete 'hidden? (package-properties
python-pip-run-bootstrap)))))
@@ -22440,7 +22433,6 @@ (define-public python-inflect
python-pytest
python-pytest-checkdocs
python-pytest-enabler
- python-pytest-flake8
python-pytest-mypy
;; For the version number
python-setuptools-scm
@@ -27627,7 +27619,6 @@ (define-public python-tempora
python-pytest
python-pytest-checkdocs
python-pytest-enabler
- python-pytest-flake8
python-pytest-freezegun
python-pytest-mypy
python-setuptools-scm
@@ -31397,8 +31388,7 @@ (define-public python-cairosvg
(list python-cairocffi python-cssselect2 python-defusedxml
python-pillow python-tinycss2))
(native-inputs
- (list python-pytest-flake8
- python-pytest-isort
+ (list python-pytest-isort
python-pytest-runner
python-setuptools
python-wheel))