* gnu/packages/check.scm (python-pytest-perf, python-pytest-enabler)
[native-inputs]: Remove python-pytest-black.
* gnu/packages/python-web.scm (python-portend)[native-inputs]:
Remove python-pytest-black.
---
gnu/packages/check.scm | 2 --
gnu/packages/python-web.scm | 1 -
gnu/packages/python-xyz.scm | 10 ----------
3 files changed, 13 deletions(-)
@@ -2830,7 +2830,6 @@ (define-public python-pytest-enabler
python-jaraco-functools
python-toml))
(native-inputs (list python-pytest
- python-pytest-black
python-pytest-checkdocs
python-pytest-flake8
python-pytest-mypy
@@ -3036,7 +3035,6 @@ (define-public python-pytest-perf
"and not upstream_url"))))
(native-inputs
(list python-pytest
- python-pytest-black
python-pytest-checkdocs
python-pytest-enabler
python-pytest-flake8
@@ -628,7 +628,6 @@ (define-public python-portend
(propagated-inputs (list python-tempora))
;; TODO: Add python-pytest-ruff to native-inputs once it has been packaged.
(native-inputs (list python-pytest
- python-pytest-black
python-pytest-checkdocs
python-pytest-enabler
python-pytest-mypy
@@ -12555,7 +12555,6 @@ (define-public python-importlib-resources
(string-append (getcwd) "/_custom_build")))))))
(native-inputs
(list python-pytest
- python-pytest-black
python-pytest-checkdocs
python-pytest-enabler
python-pytest-flake8
@@ -12705,7 +12704,6 @@ (define-public python-jaraco-classes
#:test-flags '(list "-k" "not project")))
(native-inputs
(list python-pytest
- python-pytest-black
python-pytest-checkdocs
python-pytest-flake8
python-pytest-mypy
@@ -12738,7 +12736,6 @@ (define-public python-jaraco-collections
;; TODO: Add python-pytest-ruff to native-inputs once it has been
;; packaged.
(native-inputs (list python-pytest
- python-pytest-black
python-pytest-checkdocs
python-pytest-enabler
python-pytest-mypy
@@ -12798,7 +12795,6 @@ (define-public python-jaraco-context
#:test-flags '(list "-k" "not project")))
(native-inputs
(list python-pytest
- python-pytest-black
python-pytest-checkdocs
python-pytest-flake8
python-pytest-mypy
@@ -12832,7 +12828,6 @@ (define-public python-jaraco-functools
(native-inputs
(list python-jaraco-classes
python-pytest
- python-pytest-black
python-pytest-checkdocs
python-pytest-flake8
python-pytest-mypy
@@ -12926,7 +12921,6 @@ (define-public python-jaraco-text
;; TODO: Add python-pytest-ruff to native-inputs once it has been
;; packaged.
(native-inputs (list python-pytest
- python-pytest-black
python-pytest-checkdocs
python-pytest-enabler
python-pytest-mypy
@@ -17732,7 +17726,6 @@ (define-public python-path
python-packaging
python-pygments
python-pytest
- python-pytest-black
python-pytest-checkdocs
python-pytest-enabler
python-pytest-flake8
@@ -17837,7 +17830,6 @@ (define-public python-pip-run
(append python-nbformat
python-pygments
python-pytest
- python-pytest-black
python-pytest-checkdocs
python-pytest-enabler
python-pytest-flake8
@@ -22446,7 +22438,6 @@ (define-public python-inflect
(propagated-inputs (list python-pydantic))
(native-inputs (list python-pygments
python-pytest
- python-pytest-black
python-pytest-checkdocs
python-pytest-enabler
python-pytest-flake8
@@ -27634,7 +27625,6 @@ (define-public python-tempora
(native-inputs
(list python-freezegun
python-pytest
- python-pytest-black
python-pytest-checkdocs
python-pytest-enabler
python-pytest-flake8