[bug#70858,v3,14/28] build-system/pyproject: Remove python-codecov native-input.
Commit Message
* gnu/packages/android.scm (python-androguard)[native-inputs]: Remove
python-codecov.
* gnu/packages/astronomy.scm (python-wiimatch, python-tweakwcs)
[native-inputs]: Remove python-codecov.
* gnu/packages/python-xyz.scm (python-can,
python-ddlparse)[native-inputs]: Remove python-codecov.
---
gnu/packages/android.scm | 2 +-
gnu/packages/astronomy.scm | 9 +++++----
gnu/packages/python-xyz.scm | 4 +---
3 files changed, 7 insertions(+), 8 deletions(-)
@@ -1074,7 +1074,7 @@ (define-public python-androguard
(lambda _
(invoke "nosetests" "--with-timer" "--timer-top-n" "50"))))))
(native-inputs
- (list python-codecov python-mock python-nose python-nose-timer))
+ (list python-mock python-nose python-nose-timer))
(propagated-inputs
(list python-asn1crypto
python-colorama
@@ -6399,8 +6399,7 @@ (define-public python-tweakwcs
python-stsci-imagestats
python-stsci-stimage))
(native-inputs
- (list python-codecov
- python-pytest
+ (list python-pytest
python-pytest-cov
python-scipy
python-setuptools
@@ -6523,8 +6522,10 @@ (define-public python-wiimatch
"15kq7z30m9i286ncs9xvpaq3dq1p5fa47jz21prq146qwr7j6dm8"))))
(build-system pyproject-build-system)
(propagated-inputs (list python-numpy python-scipy))
- (native-inputs (list python-codecov python-pytest python-pytest-cov
- python-pytest-doctestplus python-setuptools-scm
+ (native-inputs (list python-pytest
+ python-pytest-cov
+ python-pytest-doctestplus
+ python-setuptools-scm
python-wheel))
(home-page "https://github.com/spacetelescope/wiimatch")
(synopsis
@@ -4148,7 +4148,6 @@ (define-public python-can
python-setuptools))
(native-inputs
(list ;; python-canalystii ; Not packed yet
- python-codecov
python-future
python-hypothesis
python-mock
@@ -6259,8 +6258,7 @@ (define-public python-ddlparse
(base32 "1nh8m6rxslwk05daxshxmgk41qfp18yynydba49b13l4m8dnh634"))))
(build-system pyproject-build-system)
(native-inputs
- (list python-codecov
- python-pytest
+ (list python-pytest
python-pytest-cov
python-setuptools
python-tox