[bug#68150,v3,2/8] gnu: netsurf: Actually use glib-or-gtk-build-system.

Message ID 20250124114934.24600-3-ngraves@ngraves.fr
State New
Headers
Series Fix usage of glib-or-gtk-build-system |

Commit Message

Nicolas Graves Jan. 24, 2025, 11:48 a.m. UTC
  From: Tomas Volf <~@wolfsden.cz>

The #:modules argument was based on %glib-or-gtk-build-system-modules, which,
despite the name, should go into #:imported-modules.  When put into #:modules,
it leads to following warning:

    WARNING: (guile-user): `%standard-phases' imported from both (guix build glib-or-gtk-build-system) and (guix build gnu-build-system)

Due to the definition of %glib-or-gtk-build-system-modules

    `((guix build glib-or-gtk-build-system)
      ,@%gnu-build-system-modules)

It results in %standard-phases from gnu-build-system being used, effectively
turning glib-or-gtk-build-system with #:modules set to
%glib-or-gtk-build-system-modules into gnu-build-system.

The solution is to use the (now) exported default value of
 #:modules (%glib-or-gtk-build-system-default-modules) as a base of the
 #:modules.

* gnu/packages/web.scm (netsurf)[arguments]<#:modules>: Use
%glib-or-gtk-build-system-default-modules instead of
%glib-or-gtk-build-system-modules.

Change-Id: Iacc4df7e213dbdae5a783e3aedde7e6e20402025
---
 gnu/packages/web.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
  

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b781c13b62..58384a193f 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6344,7 +6344,7 @@  (define-public netsurf
                   (ice-9 match)
                   (srfi srfi-1)
                   (sxml simple)
-                  ,@%glib-or-gtk-build-system-modules)
+                  ,@%glib-or-gtk-build-system-default-modules)
        #:phases
        (modify-phases %standard-phases
          (delete 'configure)