[bug#75708,v2,08/14] gnu: python-sympy: Update to 1.13.3.
Commit Message
* gnu/packages/python-xyz.scm (python-sympy): Update to 1.13.3.
[build-system]: Switch to pyproject-build-system.
[arguments]<#:phases>: Adjust 'check phase.
[native-inputs]: New field to add python-hypothesis, python-pytest,
python-setuptools and python-wheel.
---
gnu/packages/python-xyz.scm | 24 ++++++++++++++----------
1 file changed, 14 insertions(+), 10 deletions(-)
@@ -14963,24 +14963,28 @@ (define-public python-syllables
(define-public python-sympy
(package
(name "python-sympy")
- (version "1.11.1")
+ (version "1.13.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "sympy" version))
(sha256
- (base32 "0n46x1rfy8c2a9za3yp2va5icigxj805f9fmiq8c1drwwvf808z3"))))
- (build-system python-build-system)
+ (base32 "1nf4zrjjbnv47n6sl6x9blfyarski61vdjaz4ygb62hfag3d4zxj"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
+ '(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke
- (or (which "python3") (which "python"))
- "-c" "import sympy; sympy.test(\"/core\")"))))))
- (propagated-inputs
- (list python-mpmath))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "python3" "-c"
+ "import sympy; sympy.test(\"/core\")")))))))
+ (propagated-inputs (list python-mpmath))
+ (native-inputs
+ (list python-hypothesis
+ python-pytest
+ python-setuptools
+ python-wheel))
(home-page "https://www.sympy.org/")
(synopsis "Python library for symbolic mathematics")
(description