[bug#73228,v1] * gnu/packages/fonts.scm (font-gnu-unifont): Update to 16.0.02.

Message ID 20250122135644.2058-1-ashvithshetty10@gmail.com
State New
Headers
Series [bug#73228,v1] * gnu/packages/fonts.scm (font-gnu-unifont): Update to 16.0.02. |

Commit Message

Ashvith Shetty Jan. 22, 2025, 1:56 p.m. UTC
  From: gemmaro <gemmaro.dev@gmail.com>

[source] <snippet>: Skip the thumbnails task.
[arguments] <#:phases>: Replace "/bin/sh" without the "-s" flag.

Co-authored-by: Ashvith Shetty <ashvithshetty10@gmail.com>
Change-Id: Ied77b86c51702623b7ca1b5850c9117d0e33d2d7
---
 gnu/packages/fonts.scm                        | 16 ++--
 ...fonts.scm-font-gnu-unifont-Update-to.patch | 73 +++++++++++++++++++
 2 files changed, 84 insertions(+), 5 deletions(-)
 create mode 100644 outgoing/v1-0001-gnu-packages-fonts.scm-font-gnu-unifont-Update-to.patch
  

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 4dbbca69dc..1bc07956c9 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -55,11 +55,12 @@ 
 ;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
 ;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
 ;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
-;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2023, 2024 gemmaro <gemmaro.dev@gmail.com>
 ;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;; Copyright © 2023 chris <chris@bumblehead.com>
 ;;; Copyright © 2023, 2024 Luis Felipe López Acevedo <sirgazil@zoho.com>
 ;;; Copyright © 2024 Christina O'Donnell <cdo@mutix.org>
+;;; Copyright © 2025 Ashvith Shetty <ashvithshetty10@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1054,7 +1055,7 @@  (define-public font-anonymous-pro-minus
 (define-public font-gnu-unifont
   (package
     (name "font-gnu-unifont")
-    (version "15.1.05")
+    (version "16.0.02")
     (source
      (origin
        (method url-fetch)
@@ -1064,11 +1065,16 @@  (define-public font-gnu-unifont
              (string-append "mirror://gnu/unifont/unifont-"
                             version "/unifont-" version ".tar.gz")))
        (sha256
-        (base32 "1yi33kxlgw7ds99za5bclh537sw8ggl94nrhhq7hwxaq8dgzaxfj"))
+        (base32 "0bd5mf3j7f0wggh9ss3a6rji62qwcfak37q6zb8lq9pjcf3yqa7i"))
        (snippet
         '(begin
            (use-modules (guix build utils))
-           (delete-file-recursively "font/precompiled")))))
+           (delete-file-recursively "font/precompiled")
+           ;; Skip thumbnail generation as it requires ImageMagick and the generated
+           ;; thumbnails will not be installed.
+           (substitute* "font/Makefile"
+             (("^(compiled-files:.+)thumbnails(.+)" _ pre post)
+              (string-append pre post "\n")))))))
     (build-system gnu-build-system)
     (outputs '("out"   ; TrueType/OpenType version
                "pcf"   ; PCF (bitmap) version
@@ -1086,7 +1092,7 @@  (define-public font-gnu-unifont
          (add-after 'unpack 'patch-source
            (lambda _
              (substitute* (find-files "." "Makefile")
-               (("/bin/sh -s") (string-append (which "sh") " -s")))))
+               (("/bin/sh\\b") (which "sh")))))
          (replace 'install
           (lambda* (#:key make-flags outputs #:allow-other-keys)
             (let* ((ttf (string-append (assoc-ref outputs "out")
diff --git a/outgoing/v1-0001-gnu-packages-fonts.scm-font-gnu-unifont-Update-to.patch b/outgoing/v1-0001-gnu-packages-fonts.scm-font-gnu-unifont-Update-to.patch
new file mode 100644
index 0000000000..18f773d76b
--- /dev/null
+++ b/outgoing/v1-0001-gnu-packages-fonts.scm-font-gnu-unifont-Update-to.patch
@@ -0,0 +1,73 @@ 
+From 52e842f50b020fb122f032cdbac78bb285a2f562 Mon Sep 17 00:00:00 2001
+From: gemmaro <gemmaro.dev@gmail.com>
+Date: Wed, 22 Jan 2025 19:16:35 +0530
+Subject: [PATCH v1] * gnu/packages/fonts.scm (font-gnu-unifont): Update to
+ 16.0.02.
+
+[source] <snippet>: Skip the thumbnails task.
+[arguments] <#:phases>: Replace "/bin/sh" without the "-s" flag.
+
+Co-authored-by: Ashvith Shetty <ashvithshetty10@gmail.com>
+Change-Id: Ied77b86c51702623b7ca1b5850c9117d0e33d2d7
+---
+ gnu/packages/fonts.scm | 16 +++++++++++-----
+ 1 file changed, 11 insertions(+), 5 deletions(-)
+
+diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
+index 4dbbca69dc..79b93662b1 100644
+--- a/gnu/packages/fonts.scm
++++ b/gnu/packages/fonts.scm
+@@ -55,11 +55,12 @@
+ ;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
+ ;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
+ ;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
+-;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
++;;; Copyright © 2023, 2024 gemmaro <gemmaro.dev@gmail.com>
+ ;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+ ;;; Copyright © 2023 chris <chris@bumblehead.com>
+ ;;; Copyright © 2023, 2024 Luis Felipe López Acevedo <sirgazil@zoho.com>
+ ;;; Copyright © 2024 Christina O'Donnell <cdo@mutix.org>
++;;; Copyright © 2025 Ashvith Shetty <ashvithshetty10@gmail.com>
+ ;;;
+ ;;; This file is part of GNU Guix.
+ ;;;
+@@ -1054,7 +1055,7 @@ (define-public font-anonymous-pro-minus
+ (define-public font-gnu-unifont
+   (package
+     (name "font-gnu-unifont")
+-    (version "15.1.05")
++    (version "16.0.02")
+     (source
+      (origin
+        (method url-fetch)
+@@ -1064,11 +1065,16 @@ (define-public font-gnu-unifont
+              (string-append "mirror://gnu/unifont/unifont-"
+                             version "/unifont-" version ".tar.gz")))
+        (sha256
+-        (base32 "1yi33kxlgw7ds99za5bclh537sw8ggl94nrhhq7hwxaq8dgzaxfj"))
++        (base32 "0bd5mf3j7f0wggh9ss3a6rji62qwcfak37q6zb8lq9pjcf3yqa7i"))
+        (snippet
+         '(begin
+            (use-modules (guix build utils))
+-           (delete-file-recursively "font/precompiled")))))
++           (delete-file-recursively "font/precompiled")
++           ;; Skip thumbnail generation as it requires ImageMagick and the generated
++           ;; thumbnails will not be installed.
++           (substitute* "font/Makefile"
++             (("^(compiled-files:.+)thumbnails(.+)" _ pre post)
++              (string-append pre post "\n")))))))
+     (build-system gnu-build-system)
+     (outputs '("out"   ; TrueType/OpenType version
+                "pcf"   ; PCF (bitmap) version
+@@ -1086,7 +1092,7 @@ (define-public font-gnu-unifont
+          (add-after 'unpack 'patch-source
+            (lambda _
+              (substitute* (find-files "." "Makefile")
+-               (("/bin/sh -s") (string-append (which "sh") " -s")))))
++               (("/bin/sh\\b") (which "sh")))))
+          (replace 'install
+           (lambda* (#:key make-flags outputs #:allow-other-keys)
+             (let* ((ttf (string-append (assoc-ref outputs "out")
+-- 
+2.47.1
+