[bug#75737,v2,100/118] gnu: ruby-yaml-lint: Update to 0.1.2-0.d6a253f.

Message ID 20250121205917.6222-100-ngraves@ngraves.fr
State New
Headers
Series None |

Commit Message

Nicolas Graves Jan. 21, 2025, 8:58 p.m. UTC
  * gnu/packages/ruby.scm (ruby-yaml-lint): Update to 0.1.2-0.d6a253f.
---
 gnu/packages/ruby.scm | 56 ++++++++++++++++++++++---------------------
 1 file changed, 29 insertions(+), 27 deletions(-)
  

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index f4f71bdd89..fd57bce732 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -14579,35 +14579,37 @@  (define-public ruby-safe-yaml
     (license license:expat)))
 
 (define-public ruby-yaml-lint
-  (package
-    (name "ruby-yaml-lint")
-    (version "0.0.10")
-    (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
+  ;; No tags for releases.
+  (let ((commit "d6a253f7d33234a9c24660d582cf7014e882c0c2")
+        (revision "0"))
+    (package
+      (name "ruby-yaml-lint")
+      (version (git-version "0.1.2" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
                (url "https://github.com/Pryz/yaml-lint")
-               (commit version)))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32
-          "1jz26mxjkdyjbgqp7f9isnzd1i6vkizsswyj1v639nmq31hwfh0d"))))
-    (build-system ruby-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "rspec")))))))
-    (native-inputs
-     (list ruby-coveralls ruby-rspec ruby-simplecov))
-    (synopsis "Simple YAML check tool")
-    (description
-     "@code{yaml-lint} will simply try to load the YAML file with the built-in
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0zk0jwzmcaaiyixjvkzdb54xhiqcnjkma72nkv0vm5csaphfdjkx"))))
+      (build-system ruby-build-system)
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (replace 'check
+             (lambda* (#:key tests? #:allow-other-keys)
+               (when tests?
+                 (invoke "rspec")))))))
+      (native-inputs
+       (list ruby-coveralls ruby-rspec ruby-simplecov))
+      (synopsis "Simple YAML check tool")
+      (description
+       "@code{yaml-lint} will simply try to load the YAML file with the built-in
 Ruby yaml library.")
-    (home-page "https://github.com/Pryz/yaml-lint")
-    (license license:expat)))
+      (home-page "https://github.com/Pryz/yaml-lint")
+      (license license:expat))))
 
 (define-public ruby-matrix
   (package