* gnu/packages/qt.scm (qtbase-5),
gnu/packages/tex.scm (texlive-hyphen-complete),
gnu/packages/texlive.scm (texlivebin),
gnu/packages/webkit.scm (webkitgtk),
gnu/packages/julia.scm (julia),
gnu/packages/textutils.scm (utf8proc-2.7.0): Add comments for
migration to ruby@3.
---
gnu/packages/julia.scm | 1 +
gnu/packages/qt.scm | 2 ++
gnu/packages/tex.scm | 1 +
gnu/packages/texlive.scm | 1 +
gnu/packages/textutils.scm | 1 +
gnu/packages/webkit.scm | 1 +
6 files changed, 7 insertions(+)
@@ -526,6 +526,7 @@ (define-public julia
("p7zip" ,p7zip)
("pcre2" ,pcre2)
("suitesparse" ,suitesparse)
+ ;; TODO Move dependent ruby to ruby@3 on the next rebuild cycle.
("utf8proc" ,utf8proc-2.7.0)
("wget" ,wget)
("which" ,which)
@@ -573,6 +573,7 @@ (define-public qtbase-5
pkg-config
python
vulkan-headers
+ ;; TODO Move to ruby@3 on the next rebuild cycle.
ruby-2.7))
(arguments
`(#:disallowed-references ,(list python)
@@ -3337,6 +3338,7 @@ (define-public qtwebengine-5
pkg-config
python2-six
python-2
+ ;; TODO Move to ruby@3 on the next rebuild cycle.
ruby-2.7))
(inputs
(list alsa-lib
@@ -707,6 +707,7 @@ (define-public texlive-hyphen-complete
(invoke "ruby" "generate-ptex-patterns.rb"))))))))
(native-inputs
;; TODO: Remove input labels on next rebuild cycle.
+ ;; TODO: Update to ruby@3 on next rebuild-cycle.
`(("ruby" ,ruby-2.7)
("ruby-hydra-minimal" ,ruby-hydra-minimal/pinned)
;; Build phase requires "docstrip.tex" from TEXLIVE-LATEX.
@@ -136,6 +136,7 @@ (define texlivebin
("pixman" ,pixman)
("potrace" ,potrace)
("python" ,python)
+ ;; TODO Move to ruby@3 on the next rebuild cycle.
("ruby" ,ruby-2.7)
("tcsh" ,tcsh)
("teckit" ,teckit)
@@ -267,6 +267,7 @@ (define-public utf8proc-2.7.0
(sha256
(base32 "1g77s8g9443dd92f82pbkim7rk51s7xdwa3mxpzb1lcw8ryxvvg3"))))
;; For tests
+ ;; TODO Move to ruby@3 on the next rebuild cycle.
("ruby" ,ruby-2.7)))))))
(define-public libconfuse
@@ -235,6 +235,7 @@ (define-public webkitgtk
pkg-config
python-wrapper
gi-docgen
+ ;; TODO Move to ruby@3 on the next rebuild cycle.
ruby-2.7
unifdef))
(propagated-inputs