[bug#75737,v2,023/118] gnu: packages: Add comments for migration to ruby@3

Message ID 20250121183835.2080-23-ngraves@ngraves.fr
State New
Headers
Series [bug#75737,v2,001/118] gnu: ruby: Remove uneeded trailing #t. |

Commit Message

Nicolas Graves Jan. 21, 2025, 6:36 p.m. UTC
  * gnu/packages/qt.scm (qtbase-5),
gnu/packages/tex.scm (texlive-hyphen-complete),
gnu/packages/texlive.scm (texlivebin),
gnu/packages/webkit.scm (webkitgtk),
gnu/packages/julia.scm (julia),
gnu/packages/textutils.scm (utf8proc-2.7.0): Add comments for
migration to ruby@3.
---
 gnu/packages/julia.scm     | 1 +
 gnu/packages/qt.scm        | 2 ++
 gnu/packages/tex.scm       | 1 +
 gnu/packages/texlive.scm   | 1 +
 gnu/packages/textutils.scm | 1 +
 gnu/packages/webkit.scm    | 1 +
 6 files changed, 7 insertions(+)
  

Patch

diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index 9668b3fd1e..e2f87307da 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -526,6 +526,7 @@  (define-public julia
        ("p7zip" ,p7zip)
        ("pcre2" ,pcre2)
        ("suitesparse" ,suitesparse)
+       ;; TODO Move dependent ruby to ruby@3 on the next rebuild cycle.
        ("utf8proc" ,utf8proc-2.7.0)
        ("wget" ,wget)
        ("which" ,which)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 76c11af543..603ef505a8 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -573,6 +573,7 @@  (define-public qtbase-5
            pkg-config
            python
            vulkan-headers
+           ;; TODO Move to ruby@3 on the next rebuild cycle.
            ruby-2.7))
     (arguments
      `(#:disallowed-references ,(list python)
@@ -3337,6 +3338,7 @@  (define-public qtwebengine-5
            pkg-config
            python2-six
            python-2
+           ;; TODO Move to ruby@3 on the next rebuild cycle.
            ruby-2.7))
     (inputs
      (list alsa-lib
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bfc923c8e3..c9f2132751 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -707,6 +707,7 @@  (define-public texlive-hyphen-complete
                   (invoke "ruby" "generate-ptex-patterns.rb"))))))))
     (native-inputs
      ;; TODO: Remove input labels on next rebuild cycle.
+     ;; TODO: Update to ruby@3 on next rebuild-cycle.
      `(("ruby" ,ruby-2.7)
        ("ruby-hydra-minimal" ,ruby-hydra-minimal/pinned)
        ;; Build phase requires "docstrip.tex" from TEXLIVE-LATEX.
diff --git a/gnu/packages/texlive.scm b/gnu/packages/texlive.scm
index 36bbf4beb8..c2a35e120e 100644
--- a/gnu/packages/texlive.scm
+++ b/gnu/packages/texlive.scm
@@ -136,6 +136,7 @@  (define texlivebin
        ("pixman" ,pixman)
        ("potrace" ,potrace)
        ("python" ,python)
+       ;; TODO Move to ruby@3 on the next rebuild cycle.
        ("ruby" ,ruby-2.7)
        ("tcsh" ,tcsh)
        ("teckit" ,teckit)
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 6091d1ea6d..cc783cfc56 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -267,6 +267,7 @@  (define-public utf8proc-2.7.0
               (sha256
                (base32 "1g77s8g9443dd92f82pbkim7rk51s7xdwa3mxpzb1lcw8ryxvvg3"))))
           ;; For tests
+          ;; TODO Move to ruby@3 on the next rebuild cycle.
           ("ruby" ,ruby-2.7)))))))
 
 (define-public libconfuse
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index b71e7e3e29..176d72685e 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -235,6 +235,7 @@  (define-public webkitgtk
            pkg-config
            python-wrapper
            gi-docgen
+           ;; TODO Move to ruby@3 on the next rebuild cycle.
            ruby-2.7
            unifdef))
     (propagated-inputs