[bug#75206,rust-team,v2,3/9] gnu: rust-syn-2: Use snippet.

Message ID 20250120024919.3384691-4-aarcov@gmail.com
State New
Headers
Series Slight updates |

Commit Message

Aaron Covrig Jan. 20, 2025, 2:48 a.m. UTC
  From: Herman Rimm <herman@rimm.ee>

* gnu/packages/crates-io.scm (rust-syn-2): Add snippet.
[arguments]: Remove patch-test-suite phase.

Change-Id: I1f53f9259fc9b11ac420aed3238671b3c20b236d
---
 gnu/packages/crates-io.scm | 29 ++++++++++++++---------------
 1 file changed, 14 insertions(+), 15 deletions(-)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5705720f63..c4953f7e6c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -77442,26 +77442,25 @@  (define-public rust-syn-2
   (package
     (name "rust-syn")
     (version "2.0.90")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "syn" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-                (base32 "0cfg5dsr1x0hl6b9hz08jp1197mx0rq3xydqmqaws36xlms3p7ci"))))
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "syn" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0cfg5dsr1x0hl6b9hz08jp1197mx0rq3xydqmqaws36xlms3p7ci"))
+       (modules '((guix build utils)))
+       ;; The syn-test-suite crate is empty.
+       (snippet
+        #~(substitute* "Cargo.toml"
+            (("^\\[dev-dependencies.syn-test-suite\\]") "")
+            (("^version = \"0\"") "")
+            (("^test = \\[\"syn-test-suite/all-features\"\\]") "")))))
     (build-system cargo-build-system)
     (arguments
      ;; Tests fail to compile
      ;; error[E0463]: can't find crate for `rustc_ast` (among other errors).
      `(#:tests? #f
-       #:phases
-       (modify-phases %standard-phases
-         ;; The syn-test-suite crate is empty.
-         (add-after 'unpack 'patch-test-suite
-           (lambda _
-             (substitute* "Cargo.toml"
-               (("^\\[dev-dependencies.syn-test-suite\\]") "")
-               (("^version = \"0\"") "")
-               (("^test = \\[\"syn-test-suite/all-features\"\\]") "")))))
        #:cargo-inputs
        (("rust-proc-macro2" ,rust-proc-macro2-1)
         ("rust-quote" ,rust-quote-1)