[bug#75563,2/2] Add python-keithley2600
Commit Message
* gnu/packages/engineering.scm (python-keithley2600): New package.
Change-Id: I6cca66222816730a04d3bd712cc6bbab4b42f327
---
gnu/packages/engineering.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
@@ -4995,3 +4995,33 @@ (define-public python-pyvisa-py
Message Based communication (Serial/USB/GPIB/Ethernet) using Python and some
well developed, easy to deploy and cross platform libraries.")
(license license:expat)))
+
+(define-public python-keithley2600
+ (let ((revision "0")
+ (commit "dfb5b2de2f62a71386cb957e6dd1c38b94178050"))
+ (package
+ (name "python-keithley2600")
+ (version (git-version "2.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OE-FET/keithley2600")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19bs7lswb04a5xr4zdsknynmpllpj18nb19jcbjnzf1fs1dqg0hw"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-numpy
+ python-pyvisa
+ python-pyvisa-py))
+ (home-page "https://keithley2600.readthedocs.io/en/stable/")
+ (synopsis "Full Python driver for Keithley 2600 series of SMU")
+ (description
+ "A full Python driver for the Keithley 2600B series of source measurement
+ units. This driver provides access to base commands and higher level functions
+ such as IV measurements, transfer and output curves, etc. Base commands
+ replicate the functionality and syntax from the Keithley's internal TSP Lua
+ functions.")
+ (license license:expat))))