[bug#75525] gnu: qtbase: Increase test timeout.

Message ID 20250112213337.11877-1-hello@lnikki.la
State New
Headers
Series [bug#75525] gnu: qtbase: Increase test timeout. |

Commit Message

Leo Nikkilä Jan. 12, 2025, 9:32 p.m. UTC
  * gnu/packages/qt.scm (qtbase): Increase test timeout.
[arguments]: <#:phases>: Set QTEST_FUNCTION_TIMEOUT.
---
 gnu/packages/qt.scm | 12 ++++++++++++
 1 file changed, 12 insertions(+)
  

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 76c11af543..d2a7c52a80 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -909,7 +909,19 @@  (define-public qtbase
                   ;; due to bitness (see: https://code.qt.io/cgit/qt/qtbase.git
                   ;; /tree/src/testlib/qtestblacklist.cpp).
                   (setenv "QTEST_ENVIRONMENT" "linux ci 32bit")
+                  ;; Some tests use a lot of memory and might trigger
+                  ;; swapping, which often hits the default test timeout of
+                  ;; 300 seconds:
+                  ;;
+                  ;;     QFATAL : tst_QByteArrayLarge::qUncompress4GiBPlus() Test function timed out
+                  ;;     QFATAL : tst_QByteArrayMatcher::haystacksWithMoreThan4GiBWork() Test function timed out
+                  ;;     QFATAL : tst_QLatin1StringMatcher::haystacksWithMoreThan4GiBWork() Test function timed out
+                  ;;
+                  ;; Guix has its own timeout anyway.
+                  ;;
+                  ;; <https://doc.qt.io/qt-6/qtest-overview.html#increasing-test-function-timeout>
+                  (setenv "QTEST_FUNCTION_TIMEOUT" "3600000") ; 1 hour
                   (setenv "HOME" "/tmp") ;some tests require a writable HOME
 
                   ;; Note: the search path specified for TZDIR is only