[bug#75489] gnu: Add emacs-denote-explore.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-denote-explore): New variable.
Change-Id: I6b94926c522467607060e66e65e030efdbc5f70e
---
gnu/packages/emacs-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
@@ -18785,6 +18785,36 @@ (define-public emacs-denote-menu
view your Denote directory.")
(license license:gpl3+)))
+(define-public emacs-denote-explore
+ (package
+ (name "emacs-denote-explore")
+ (version "3.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pprevos/denote-explore")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0773691jxyv039y407c8dppkky41b3icacavddcv9m8v481763b7"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-denote emacs-dash))
+ (home-page "https://github.com/pprevos/denote-explore")
+ (synopsis "Analyse and visualise a collection of Denote notes")
+ (description
+ "The Denote-Explore package provides auxiliary functions to
+maintain and explore your collection of Denote files. Denote-Explore provides
+four groups of Emacs commands:
+@enumerate
+@item Summary statistics: Count and visualise notes, attachments and keywords.
+@item Random walks: Generate new ideas using serendipity.
+@item Janitor: Manage your denote collection.
+@item Visualisations: Visualise your Denote network as a network
+graph. (optional dependencies \"GraphViz\", \"d3js\", to be acquired separately!)
+@end enumerate")
+ (license license:gpl3)))
+
(define-public emacs-logos
(let ((commit "eeedd3ef289faa4fa2b726013255747a41a6ba9c")) ;version bump
(package