[bug#74517,v5,01/10] gnu: Add v4l-utils-minimal.

Message ID 20250108061150.30882-1-ngraves@ngraves.fr
State New
Headers
Series [bug#74517,v5,01/10] gnu: Add v4l-utils-minimal. |

Commit Message

Nicolas Graves Jan. 8, 2025, 6:11 a.m. UTC
  * gnu/packages/video.scm (v4l-utils-minimal): New variable.
---
 gnu/packages/video.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
  

Comments

Ludovic Courtès Jan. 8, 2025, 10:26 a.m. UTC | #1
Hello,

Nicolas Graves <ngraves@ngraves.fr> skribis:

> * gnu/packages/video.scm (v4l-utils-minimal): New variable.

Side note: I wonder why I’m receiving these patches since this is not in
the scope of the teams I’m in, I think?

Ludo’.
  
Ludovic Courtès Jan. 9, 2025, 1:29 p.m. UTC | #2
Nicolas Graves <ngraves@ngraves.fr> skribis:

> On 2025-01-08 11:26, Ludovic Courtès wrote:
>
>> Hello,
>>
>> Nicolas Graves <ngraves@ngraves.fr> skribis:
>>
>>> * gnu/packages/video.scm (v4l-utils-minimal): New variable.
>>
>> Side note: I wonder why I’m receiving these patches since this is not in
>> the scope of the teams I’m in, I think?
>
> Sorry, I think I put in cc people who participated by hand. 

No worries.

I was surprised because normally Git hooks are set up automatically such
that the relevant teams are Cc’d.  (Perhaps there are no relevant teams
in this case?)

Ludo’.
  
Maxim Cournoyer Jan. 17, 2025, 4:14 a.m. UTC | #3
Hi,

I think this LGTM, in its version v5.  Liliana, can we apply it to the
gnome-team branch to avoid disrupting master with many rebuilds?
  
Liliana Marie Prikler Jan. 18, 2025, 10:45 a.m. UTC | #4
Am Freitag, dem 17.01.2025 um 13:14 +0900 schrieb Maxim Cournoyer:
> Hi,
> 
> I think this LGTM, in its version v5.  Liliana, can we apply it to
> the gnome-team branch to avoid disrupting master with many rebuilds?
Sure, consider it done.

Cheers
  

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 5c878bfcb9..b91865d6af 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4052,6 +4052,20 @@  (define-public v4l-utils
     ;; libv4l2 is LGPL2.1+, while utilities are GPL2 only.
     (license (list license:lgpl2.1+ license:gpl2))))
 
+(define-public v4l-utils-minimal
+  (package/inherit v4l-utils
+    (name "v4l-utils-minimal")
+    (arguments
+     (substitute-keyword-arguments (package-arguments v4l-utils)
+       ((#:phases phases)
+        #~(modify-phases #$phases
+            (delete 'split)))
+       ((#:disallowed-references _ '())
+        (list qtbase qtbase-5))))
+    (outputs '("out"))
+    (inputs (modify-inputs (package-inputs v4l-utils)
+              (delete "qtbase")))))
+
 (define-public obs
   (package
     (name "obs")