[bug#75403] gnu: Add emacs-magit-stgit.

Message ID 20250106130035.15884-1-ngraves@ngraves.fr
State New
Headers
Series [bug#75403] gnu: Add emacs-magit-stgit. |

Commit Message

Nicolas Graves Jan. 6, 2025, 1 p.m. UTC
  * gnu/packages/emacs-xyz.scm (emacs-magit-stgit): New variable.
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
  

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bdc4cd1ebe..e615814f3a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1882,6 +1882,34 @@  (define-public emacs-magit
 rebasing, and other common Git operations.")
     (license license:gpl3+)))
 
+(define-public emacs-magit-stgit
+  (let ((commit "51168b7438dfb5ca6b9239b8564397cc0cc6e798")
+        (revision "0"))
+    (package
+      (name "emacs-magit-stgit")
+      (version (git-version "2.2.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/stacked-git/magit-stgit.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1z2dhc1m510iyrks5lxp3jlqg4n7qwwirbmxg4c4ll0xngfhnalc"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list emacs-magit emacs-transient))
+      (home-page "https://github.com/stacked-git/magit-stgit")
+      (synopsis "StGit extension for Magit")
+      (description
+       "This package provides basic support for @code{stgit} in
+@code{emacs-magit}.  When @code{magit-stgit-mode} is turned on, the
+current patch series is displayed in the status buffer.  While point is on a
+patch the changes it introduces can be shown using @code{RET}, it can be selected
+as the current patch using @code{a}, and it can be discarded using @code{k}.  Other
+@code{StGit} commands are available from the @code{StGit} transient on @code{/}.")
+      (license license:gpl3+))))
+
 (define-public emacs-magit-svn
   (package
     (name "emacs-magit-svn")