[bug#75146,v1,05/15] gnu: libxfce4ui: Update variable fields.

Message ID 20241228115320.24218-6-ashvith@noreply.codeberg.org
State New
Headers
Series XFCE: Move source from archive to git. |

Commit Message

Ashvith Shetty Dec. 28, 2024, 11:52 a.m. UTC
  From: Ashvith Shetty <Ashvith@noreply.codeberg.org>

* gnu/packages/xfce.scm (libxfce4ui):
[source]: Update to XFCE's GitLab URL.
[home-page]: Set to docs.xfce.org.
[arguments]: Set configure flag "--enable-maintainer-mode".
[native-inputs]: Add autoconf, automake, gtk-doc, libtool
and xfce4-dev-tools.

Change-Id: I9ca360cec30660b85cea95b494df9dae1767f3ab
---
 gnu/packages/xfce.scm | 43 +++++++++++++++++++++++++------------------
 1 file changed, 25 insertions(+), 18 deletions(-)
  

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index a60f4515b1..8587d2d8c1 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -186,27 +186,34 @@  (define-public libxfce4ui
   (package
     (name "libxfce4ui")
     (version "4.20.0")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://archive.xfce.org/src/xfce/"
-                                  name "/" (version-major+minor version) "/"
-                                  name "-" version ".tar.bz2"))
-              (sha256
-               (base32
-                "1vpafvmn2x95n0d8dmr6pp81w8bw2ksicp6dvsm7a0zjhilrks3m"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.xfce.org/xfce/libxfce4ui")
+             (commit (string-append name "-" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1ps8sq8g43dx12qp0shrdb45bjrfhhgkziscj5jnrzfhy6j9mqrk"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:configure-flags
-       (list "--with-vendor-info=GNU Guix")))
-    (native-inputs
-     (list pkg-config intltool gobject-introspection))
-    (propagated-inputs
-     (list gtk+    ; required by libxfce4ui-2.pc
-           ;; libxfce4kbd-private-3.pc refers to all these.
-           libxfce4util
-           xfconf))
+     `(#:configure-flags (list "--with-vendor-info=GNU Guix"
+                               "--enable-maintainer-mode")))
+    (native-inputs (list autoconf
+                         automake
+                         gobject-introspection
+                         gtk-doc
+                         libtool
+                         intltool
+                         pkg-config
+                         xfce4-dev-tools))
+    (propagated-inputs (list
+                        ;; required by libxfce4ui-2.pc
+                        gtk+
+                        ;; libxfce4kbd-private-3.pc refers to all these.
+                        libxfce4util xfconf))
     (inputs (list libgtop libice libsm startup-notification))
-    (home-page "https://www.xfce.org/")
+    (home-page "https://docs.xfce.org/xfce/libxfce4util/")
     (synopsis "Widgets library for Xfce")
     (description
      "Libxfce4ui is the replacement of the old libxfcegui4 library.  It is used