[bug#75146,v1,13/15] gnu: xfce4-battery-plugin: Update to 1.1.6.
Commit Message
From: Ashvith Shetty <Ashvith@noreply.codeberg.org>
* gnu/packages/xfce.scm (xfce4-battery-plugin): Update to 1.1.6.
[source]: Update to XFCE's GitLab URL.
[home-page]: Set to docs.xfce.org.
[arguments]: Set configure flag "--enable-maintainer-mode".
[native-inputs]: Add autoconf, automake, gtk-doc, libtool and
xfce4-dev-tools.
Change-Id: I9359731b564a225450cf314b762d51564cce370e
---
gnu/packages/xfce.scm | 33 +++++++++++++++++++++------------
1 file changed, 21 insertions(+), 12 deletions(-)
@@ -534,20 +534,29 @@ (define-public xfce4-panel
(define-public xfce4-battery-plugin
(package
(name "xfce4-battery-plugin")
- (version "1.1.5")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://archive.xfce.org/src/panel-plugins/"
- name "/" (version-major+minor version) "/"
- name "-" version ".tar.bz2"))
- (sha256
- (base32
- "04z2bic6c2cgl6wy4qrhfdigb6c2hsxnqraa20k1xvi0nfzk68km"))))
+ (version "1.1.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.xfce.org/panel-plugins/xfce4-battery-plugin")
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1bd912j22pf6rmqvkc80g5axjil88pbzxqa68krw65l11v73icmm"))))
(build-system gnu-build-system)
- (native-inputs (list pkg-config intltool))
+ (arguments
+ (list
+ #:configure-flags #~(list "--enable-maintainer-mode")))
+ (native-inputs (list autoconf
+ automake
+ gtk-doc
+ intltool
+ libtool
+ pkg-config
+ xfce4-dev-tools))
(inputs (list glib gtk+ libxfce4util libxfce4ui xfce4-panel))
- (home-page
- "https://goodies.xfce.org/projects/panel-plugins/xfce4-battery-plugin")
+ (home-page "https://docs.xfce.org/panel-plugins/xfce4-battery-plugin/")
(synopsis "Battery monitor panel plugin for Xfce4")
(description
"A battery monitor panel plugin for Xfce4, compatible with APM and ACPI.")