[bug#75077] gnu: Add swayimg.
Commit Message
Change-Id: I10d098561084117c741cf04bf4da967b411e2729
---
This is my first guix patxh and my first email patch ever!
gnu/packages/image-viewers.scm | 45 ++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)
@@ -111,6 +111,51 @@ (define-module (gnu packages image-viewers)
#:use-module (gnu packages xorg)
#:use-module (gnu packages))
+(define-public swayimg
+ (package
+ (name "swayimg")
+ (version "3.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/artemsen/swayimg")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "15nqb1igikkvrzx3dhyj9msynfpvrnqvql6plqm8fhg10fbimfhd"))))
+ (build-system meson-build-system)
+ (native-inputs (list pkg-config giflib))
+ (inputs (list wayland
+ json-c
+ libxkbcommon
+ fontconfig
+ freetype
+ openexr
+ libheif
+ libavif
+ ijg-libjpeg
+ libjxl
+ libpng
+ librsvg
+ libtiff
+ libwebp
+ libexif
+ bash-completion
+ wayland-protocols))
+ (home-page "https://github.com/artemsen/swayimg/tree/master")
+ (synopsis "Customizable and lightweight image viewer for Wayland")
+ (description
+ "Fully customizable and lightweight image viewer for Wayland based display
+servers. Support for the most popular image formats (JPEG, JPEG XL, PNG, GIF,
+SVG, WebP, HEIF/AVIF, AV1F/AVIFS, TIFF, EXR, BMP, PNM, TGA, QOI, DICOM,
+Farbfeld). Fully customizable keyboard bindings, colors, and many other
+parameters. Loading images from files and pipes. Gallery and viewer modes with
+slideshow and animation support. Preload images in a separate thread. Cache in
+memory, no data is written to permanent storage. Sway integration mode: the
+application creates an \"overlay\" above the currently active window, which
+gives the illusion that you are opening the image directly in a terminal window.")
+ (license license:expat)))
+
(define-public ytfzf
(package
(name "ytfzf")