[bug#75057] gnu: Add emacs-spacious-padding.
Commit Message
From: hapster <o.rojon@posteo.net>
* gnu/packages/emacs-xyz.scm (emacs-spacious-padding): New package
Change-Id: I50b76db1ca490a2d0bec66124ab370f114ffe49b
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
@@ -148,6 +148,7 @@
;;; Copyright © 2024 Spencer King <spencer.king@nursiapress.com>
;;; Copyright © 2024 emma thompson <bigbookofbug@proton.me>
;;; Copyright © 2024 Liam Hupfer <liam@hpfr.net>
+;;; Copyright © 2024 Olivier Rojon <o.rojon@posteo.net>
;;;
;;; This file is part of GNU Guix.
@@ -1447,6 +1448,27 @@ (define-public emacs-prism
face properties and allows configuration of faces and colors.")
(license license:gpl3+))))
+(define-public emacs-spacious-padding
+ (package
+ (name "emacs-spacious-padding")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/spacious-padding-"
+ version ".tar"))
+ (sha256
+ (base32 "0x5bsyd6b1d3bzrsrpf9nvw7xj5ch114m2dilq64bg8y2db3452z"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/protesilaos/spacious-padding")
+ (synopsis "Increase the padding/spacing of frames and windows")
+ (description
+ "The spacious-padding-mode increases the space or padding around several
+elements of the Emacs interface, such as window dividers, the internal frame
+border, the padding of the mode line, and more. The idea is to produce a more
+comfortable presentation.")
+ (license license:gpl3+)))
+
(define-public emacs-project
(package
(name "emacs-project")