[bug#75033,v3] gnu: python-pypandoc: Fix build

Message ID 20241223133151.1814674-1-aaron.covrig.us@ieee.org
State New
Headers
Series [bug#75033,v3] gnu: python-pypandoc: Fix build |

Commit Message

Aaron Covrig Dec. 23, 2024, 1:30 p.m. UTC
  * gnu/packages/python-xyz.scm (python-pypandoc): Fix build
---
Fixing extra space in previous commit (which adds pyproject required
dependencies and updates the project homepage to remove the redirection)

 gnu/packages/python-xyz.scm | 11 +++++++----
 1 file changed, 7 insertions(+), 4 deletions(-)


base-commit: 30fdffc4b5605431b28a23b03330e850b2184a76
  

Comments

jgart Dec. 23, 2024, 5:02 p.m. UTC | #1
Hi all,

I applied this.

Hi Aaron,

Yes, I think we are moving to the pyproject-build-system.

That documentation should probably be updated.

I'll try to take a look or feel free to update it and Cc the python
team for review.
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fe2b4b6d56..0b978b1537 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -33730,12 +33730,15 @@  (define-public python-pypandoc
                          "skip_test_conversion_with_data_files")) #t)))))
     ;; Ideally, we would supersede texlive-xpatch with texlive-regexpatch once
     ;; the missing etoolbox.sty file is added
-    (native-inputs (list python-poetry-core
-                         (texlive-updmap.cfg (list texlive-xpatch texlive-lm
-                                                   texlive-xcolor))))
+    (native-inputs (list (texlive-updmap.cfg (list texlive-xpatch texlive-lm
+                                                   texlive-xcolor))
+                         ;; Dependencies required by pyproject-build-system
+                         python-poetry-core
+                         python-setuptools
+                         python-pip))
     (inputs (list pandoc python-pandocfilters))
     (propagated-inputs (list python-wheel))
-    (home-page "https://github.com/bebraw/pypandoc")
+    (home-page "https://github.com/JessicaTegner/pypandoc")
     (synopsis "Python wrapper for pandoc")
     (description "pypandoc is a thin Python wrapper around pandoc
 and pandoc-citeproc.")