[bug#74234,rust-team,v3,22/23] gnu: Add rust-ashpd-0.6.

Message ID 20241209011150.1455224-23-aaron.covrig.us@ieee.org
State New
Headers
Series WIP add gnome-authenticator |

Commit Message

Aaron Covrig Dec. 9, 2024, 1:11 a.m. UTC
  From: Giacomo Leidi <goodoldpaul@autistici.org>

* gnu/packages/crates-gtk.scm (rust-ashpd-0.6): New variable.

Change-Id: If7b758010fe8c729d7e3319869a8d9c518ade46f
---
 gnu/packages/crates-gtk.scm | 45 +++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)
  

Patch

diff --git a/gnu/packages/crates-gtk.scm b/gnu/packages/crates-gtk.scm
index 2654b1501b..4dbb324701 100644
--- a/gnu/packages/crates-gtk.scm
+++ b/gnu/packages/crates-gtk.scm
@@ -43,6 +43,51 @@  (define-module (gnu packages crates-gtk)
 ;;; Please: Try to add new module packages in alphabetic order.
 ;;;
 
+(define-public rust-ashpd-0.6
+  (package
+    (name "rust-ashpd")
+    (version "0.6.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "ashpd" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "109d7w6v0rnpy9lv4kmhwgh0sff0440s2vybj1k0ik4ib3d2xhja"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-test-flags '("--"
+                            ;; error[E0432]: unresolved import `ashpd::desktop::Color`
+                            "--skip=src/lib.rs - (line 21)")
+       #:cargo-inputs (("rust-async-fs" ,rust-async-fs-2)
+                       ("rust-async-net" ,rust-async-net-2)
+                       ("rust-async-trait" ,rust-async-trait-0.1)
+                       ("rust-enumflags2" ,rust-enumflags2-0.7)
+                       ("rust-futures-channel" ,rust-futures-channel-0.3)
+                       ("rust-futures-util" ,rust-futures-util-0.3)
+                       ("rust-gdk4-wayland" ,rust-gdk4-wayland-0.7)
+                       ("rust-gdk4-x11" ,rust-gdk4-x11-0.7)
+                       ("rust-glib" ,rust-glib-0.18)
+                       ("rust-gtk4" ,rust-gtk4-0.7)
+                       ("rust-pipewire" ,rust-pipewire-0.7)
+                       ("rust-rand" ,rust-rand-0.8)
+                       ("rust-raw-window-handle" ,rust-raw-window-handle-0.6)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-serde-repr" ,rust-serde-repr-0.1)
+                       ("rust-tokio" ,rust-tokio-1)
+                       ("rust-tracing" ,rust-tracing-0.1)
+                       ("rust-url" ,rust-url-2)
+                       ("rust-wayland-backend" ,rust-wayland-backend-0.3)
+                       ("rust-wayland-client" ,rust-wayland-client-0.30)
+                       ("rust-wayland-protocols" ,rust-wayland-protocols-0.30)
+                       ("rust-zbus" ,rust-zbus-3))
+       #:cargo-development-inputs (("rust-serde-json" ,rust-serde-json-1))))
+    (home-page "https://github.com/bilelmoussaoui/ashpd")
+    (synopsis "XDG portals wrapper in Rust using zbus")
+    (description
+     "This package provides XDG portals wrapper in Rust using zbus.")
+    (license license:expat)))
+
 (define-public rust-atk-sys-0.18
   (package
     (name "rust-atk-sys")