[bug#74234,rust-team,v3,11/23] gnu: Add rust-svg-metadata-0.5.

Message ID 20241209011150.1455224-12-aaron.covrig.us@ieee.org
State New
Headers
Series WIP add gnome-authenticator |

Commit Message

Aaron Covrig Dec. 9, 2024, 1:11 a.m. UTC
  * gnu/packages/crates-graphics.scm (rust-svg-metadata-0.5): New variable.
---
 gnu/packages/crates-graphics.scm | 37 ++++++++++++++++++++++++--------
 1 file changed, 28 insertions(+), 9 deletions(-)
  

Patch

diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index f95dc7b0a4..20bf6f2ab1 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -4525,8 +4525,35 @@  (define-public rust-softbuffer-0.3
                (setenv "DISPLAY" display)
                (system (string-append xvfb " " display " &"))))))))))
 
+(define-public rust-svg-metadata-0.5
+  (package
+    (name "rust-svg-metadata")
+    (version "0.5.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "svg_metadata" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0717wb4zkj5qdypg58zs7m1x45i49pdrhzga0k0wvqn2g2y7qk17"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-doc-comment" ,rust-doc-comment-0.3)
+                       ("rust-once-cell" ,rust-once-cell-1)
+                       ("rust-regex" ,rust-regex-1)
+                       ("rust-roxmltree" ,rust-roxmltree-0.20))
+       #:cargo-development-inputs (("rust-doc-comment" ,rust-doc-comment-0.3))))
+    (home-page "https://github.com/mre/svg-metadata")
+    (synopsis
+     "Extracts metadata (like the viewBox, width, and height) from SVG graphics")
+    (description
+     "This package provides Extracts metadata (like the @code{viewBox}, width,
+and height) from SVG graphics.")
+    (license (list license:asl2.0 license:expat))))
+
 (define-public rust-svg-metadata-0.4
   (package
+    (inherit rust-svg-metadata-0.5)
     (name "rust-svg-metadata")
     (version "0.4.4")
     (source
@@ -4536,7 +4563,6 @@  (define-public rust-svg-metadata-0.4
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "002j0na1kfz4pgi43hdcz5baygzk6irnjd5lrmbqqfjldwn3sbx4"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:cargo-test-flags '("--"
                             ;; error[E0432]: unresolved import `svg_metadata`
@@ -4545,14 +4571,7 @@  (define-public rust-svg-metadata-0.4
                        ("rust-lazy-static" ,rust-lazy-static-1)
                        ("rust-regex" ,rust-regex-1)
                        ("rust-roxmltree" ,rust-roxmltree-0.18))
-       #:cargo-development-inputs (("rust-skeptic" ,rust-skeptic-0.13))))
-    (home-page "https://github.com/mre/svg-metadata")
-    (synopsis
-     "Extracts metadata (like the viewBox, width, and height) from SVG graphics")
-    (description
-     "This package provides Extracts metadata (like the @code{viewBox}, width,
-and height) from SVG graphics.")
-    (license (list license:asl2.0 license:expat))))
+       #:cargo-development-inputs (("rust-skeptic" ,rust-skeptic-0.13))))))
 
 (define-public rust-tiff-0.9
   (package