[bug#74051,v2] gnu: Add emacs-weblorg.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-weblorg): New Variable.
Change-Id: Iae2d6cbbadec7a171e1e5b8502d4f47701d7af5b
---
gnu/packages/emacs-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)
base-commit: f129a6cc591817c5c51770d5b8712eeb344ba4e4
Comments
Thanks for the review.
I've sent back all the patches with the version number. I hope it's all
good.
Mattia
>ven. 29 nov. 2024 at 16:43, Mattia Bunel <mattia.bunel@ehess.fr> wrote:
> + (description "A static site generator particularly suitable for blogs,
> +written in Emacs Lisp and with support for templates and themes. It requires
> +no external dependencies.")
Sentences in description should be followed by two spaces.
You may check your code before submitting with:
./pre-inst-env guix lint emacs-weblorg
./pre-inst-env guix style emacs-weblorg
and your description here
https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html
Thanks !
--
Cayetano Santos
@@ -38431,6 +38431,40 @@ (define-public emacs-org-static-blog
a @samp{date} keywords, and optionally, a @samp{filetags} keyword.")
(license license:bsd-3)))
+(define-public emacs-weblorg
+ (let ((commit "0db218bd6b2e083546d3a69a022dfb1a08900acd")
+ (revision "0"))
+ (package
+ (name "emacs-weblorg")
+ (version (git-version "0.1.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-love/weblorg")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0fijrzc96p3jkq53i65bzhmxqyg28a49n21glkzb5b21agy0cdqh"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:tests? #t
+ #:test-command #~(list "emacs"
+ "--quick"
+ "--batch"
+ "-l"
+ "t/weblorg-tests.el"
+ "-f"
+ "ert-run-tests-batch-and-exit")))
+ (propagated-inputs (list emacs-templatel))
+ (home-page "https://emacs.love/weblorg/")
+ (synopsis "Static site generator for Org mode")
+ (description "A static site generator particularly suitable for blogs,
+written in Emacs Lisp and with support for templates and themes. It requires
+no external dependencies.")
+ (license license:gpl3+))))
+
(define-public emacs-ddskk
(let ((commit "8c47f46e38a29a0f3eabcd524268d20573102467")
(revision "0"))