[bug#74517,v3,01/10] gnu: Add v4l-utils-minimal.

Message ID 20241125095249.19053-1-ngraves@ngraves.fr
State New
Headers
Series [bug#74517,v3,01/10] gnu: Add v4l-utils-minimal. |

Commit Message

Nicolas Graves Nov. 25, 2024, 9:52 a.m. UTC
  * gnu/packages/video.scm (v4l-utils-minimal): New variable.
---
 gnu/packages/video.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
  

Comments

Ludovic Courtès Dec. 26, 2024, 10:12 p.m. UTC | #1
Maxim, could you take a look at v3 of this patch series?

Thanks,
Ludo’.
  
Maxim Cournoyer Dec. 28, 2024, 2:02 a.m. UTC | #2
Hi Nicolas,

Nicolas Graves <ngraves@ngraves.fr> writes:

> * gnu/packages/video.scm (v4l-utils-minimal): New variable.
> ---
>  gnu/packages/video.scm | 14 ++++++++++++++
>  1 file changed, 14 insertions(+)
>
> diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
> index 2da458ed01..6f9eea6fc2 100644
> --- a/gnu/packages/video.scm
> +++ b/gnu/packages/video.scm
> @@ -4035,6 +4035,20 @@ (define-public v4l-utils
>      ;; libv4l2 is LGPL2.1+, while utilities are GPL2 only.
>      (license (list license:lgpl2.1+ license:gpl2))))
>  
> +(define-public v4l-utils-minimal
> +  (package/inherit v4l-utils
> +    (name "v4l-utils-minimal")
> +    (arguments
> +     (substitute-keyword-arguments (package-arguments v4l-utils)
> +       ((#:phases phases)
> +        #~(modify-phases #$phases
> +            (delete 'split)))
> +       ((#:disallowed-references _)
> +        #~("qtbase"))))

I think the value of #:disallowed-references need to be a list of
packages, not strings.
  
Maxim Cournoyer Dec. 28, 2024, 3:14 a.m. UTC | #3
Hi Ludovic, Nicolas,

Ludovic Courtès <ludo@gnu.org> writes:

> Maxim, could you take a look at v3 of this patch series?

Thanks for the ping.  I've looked at v3, and it looks good to me, except
for the newly added #:disallowed-references (which I suggested adding)
which should be a list of packages, not a list of strings, if I'm not
mistaken.

Also, a #:disallowed-references added directly to GTK (to ensure it
continues not pulling in qtbase) would be a nice to have, but can be
added later too; I believe adding a disallowed reference should not lead
to rebuilds?

Nicolas, would you mind sending one last v4 with the corrected
#:disallowed-references?  You can grep for examples.  After which, I
think it should be merged to the gnome-team branch (CC'ing Liliana to
make sure it makes sense at this stage).
  
Ludovic Courtès Jan. 6, 2025, 3:07 p.m. UTC | #4
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Maxim, could you take a look at v3 of this patch series?
>
> Thanks for the ping.  I've looked at v3, and it looks good to me, except
> for the newly added #:disallowed-references (which I suggested adding)
> which should be a list of packages, not a list of strings, if I'm not
> mistaken.
>
> Also, a #:disallowed-references added directly to GTK (to ensure it
> continues not pulling in qtbase) would be a nice to have, but can be
> added later too; I believe adding a disallowed reference should not lead
> to rebuilds?

Add #:disallowed-references or #:allowed-references triggers changes the
derivation and thus triggers a rebuild.

> Nicolas, would you mind sending one last v4 with the corrected
> #:disallowed-references?  You can grep for examples.  After which, I
> think it should be merged to the gnome-team branch (CC'ing Liliana to
> make sure it makes sense at this stage).

Thanks,
Ludo’.
  
Liliana Marie Prikler Jan. 6, 2025, 3:20 p.m. UTC | #5
Hi,

Am Montag, dem 06.01.2025 um 16:07 +0100 schrieb Ludovic Courtès:
> Add[ing] #:disallowed-references or #:allowed-references triggers
> changes the derivation and thus triggers a rebuild.
> 
> > Nicolas, would you mind sending one last v4 with the corrected
> > #:disallowed-references?  You can grep for examples.  After which,
> > I think it should be merged to the gnome-team branch (CC'ing
> > Liliana to make sure it makes sense at this stage).
Yeah, we can rebuild GTK on gnome-team.  I previously submitted a
series to bump Webkit and we should probably bump all the other
packages to their latest minor version too.

Feel free to CC me for any patches that ought to go towards gnome-team
:)

Cheers
  

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2da458ed01..6f9eea6fc2 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4035,6 +4035,20 @@  (define-public v4l-utils
     ;; libv4l2 is LGPL2.1+, while utilities are GPL2 only.
     (license (list license:lgpl2.1+ license:gpl2))))
 
+(define-public v4l-utils-minimal
+  (package/inherit v4l-utils
+    (name "v4l-utils-minimal")
+    (arguments
+     (substitute-keyword-arguments (package-arguments v4l-utils)
+       ((#:phases phases)
+        #~(modify-phases #$phases
+            (delete 'split)))
+       ((#:disallowed-references _)
+        #~("qtbase"))))
+    (outputs '("out"))
+    (inputs (modify-inputs (package-inputs v4l-utils)
+              (delete "qtbase")))))
+
 (define-public obs
   (package
     (name "obs")