diff mbox series

[bug#74417] gnu: qbittorrent: Update to 5.0.1.

Message ID 20241118125341.28539-1-ron@noisytoot.org
State New
Headers show
Series [bug#74417] gnu: qbittorrent: Update to 5.0.1. | expand

Commit Message

Ron Nazarov Nov. 18, 2024, 12:53 p.m. UTC
* gnu/packages/bittorrent.scm (qbittorrent): Update to 5.0.1.
[native-inputs]: Replace qttools-5 with qttools.
[inputs]: Replace qtsvg-5 with qtsvg. Add qtbase.

Change-Id: I82dd5b65f1a812c989baa752313cd3daeaf0d8bf
---
 gnu/packages/bittorrent.scm | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

Comments

Z572 Nov. 20, 2024, 10:57 a.m. UTC | #1
Ron Nazarov via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/bittorrent.scm (qbittorrent): Update to 5.0.1.
> [native-inputs]: Replace qttools-5 with qttools.
> [inputs]: Replace qtsvg-5 with qtsvg. Add qtbase.
>
> Change-Id: I82dd5b65f1a812c989baa752313cd3daeaf0d8bf
> ---
>  gnu/packages/bittorrent.scm | 10 ++++++----
>  1 file changed, 6 insertions(+), 4 deletions(-)
>
> diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
> index 2b38c7cb65..758202d70f 100644
> --- a/gnu/packages/bittorrent.scm
> +++ b/gnu/packages/bittorrent.scm
> @@ -18,6 +18,7 @@
>  ;;; Copyright © 2022 Jacob Hart <hartja1@yahoo.com>
>  ;;; Copyright © 2022 Simon Streit <simon@netpanic.org>
>  ;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
> +;;; Copyright © 2024 Noisytoot <ron@noisytoot.org>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -510,7 +511,7 @@ (define-public libtorrent-rasterbar-1.2
>  (define-public qbittorrent
>    (package
>      (name "qbittorrent")
> -    (version "4.6.6")
> +    (version "5.0.1")
>      (source
>       (origin
>         (method git-fetch)
> @@ -519,19 +520,20 @@ (define-public qbittorrent
>               (commit (string-append "release-" version))))
>         (file-name (git-file-name name version))
>         (sha256
> -        (base32 "0kv7dgnfy8m480kxc4na9v9cjq9f9m3il191w7yvj4i8lz6jcaq1"))))
> +        (base32 "03kqir7jyrzblg4642gnf2pp8f0x68njgaalmq8qjh7dcx0d6rq6"))))
>      (build-system qt-build-system)
>      (arguments
>       (list #:configure-flags #~(list "-DTESTING=ON")
>             #:test-target "check"))
>      (native-inputs
> -     (list qttools-5))
> +     (list qttools))
>      (inputs
>       (list boost
>             libtorrent-rasterbar
>             openssl
>             python-wrapper
> -           qtsvg-5
> +           qtbase

should add qtbase to arguments's #:qtbase keyword, qt-build-system sets
different environment variables depending on the version of qtbase.

> +           qtsvg
>             zlib))
>      (home-page "https://www.qbittorrent.org/")
>      (synopsis "Graphical BitTorrent client")
and update qbittorrent to 5.0.2, qbittorrent-enhanced to 5.0.2.10.

pushed, closing.
diff mbox series

Patch

diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 2b38c7cb65..758202d70f 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2022 Jacob Hart <hartja1@yahoo.com>
 ;;; Copyright © 2022 Simon Streit <simon@netpanic.org>
 ;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2024 Noisytoot <ron@noisytoot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -510,7 +511,7 @@  (define-public libtorrent-rasterbar-1.2
 (define-public qbittorrent
   (package
     (name "qbittorrent")
-    (version "4.6.6")
+    (version "5.0.1")
     (source
      (origin
        (method git-fetch)
@@ -519,19 +520,20 @@  (define-public qbittorrent
              (commit (string-append "release-" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0kv7dgnfy8m480kxc4na9v9cjq9f9m3il191w7yvj4i8lz6jcaq1"))))
+        (base32 "03kqir7jyrzblg4642gnf2pp8f0x68njgaalmq8qjh7dcx0d6rq6"))))
     (build-system qt-build-system)
     (arguments
      (list #:configure-flags #~(list "-DTESTING=ON")
            #:test-target "check"))
     (native-inputs
-     (list qttools-5))
+     (list qttools))
     (inputs
      (list boost
            libtorrent-rasterbar
            openssl
            python-wrapper
-           qtsvg-5
+           qtbase
+           qtsvg
            zlib))
     (home-page "https://www.qbittorrent.org/")
     (synopsis "Graphical BitTorrent client")