diff mbox series

[bug#74323,rust-team] add rust-rustc-hash-2

Message ID 20241112164259.1343-2-ikbenrickhuyzer@gmail.com
State New
Headers show
Series [bug#74323,rust-team] add rust-rustc-hash-2 | expand

Commit Message

Rick Huijzer Nov. 12, 2024, 4:34 p.m. UTC
---

I need a newer version of rustc-hash because I want to upgrade
tree-sitter because I want to upgrade neovim (and so on) 

Is it acceptable this way? 

 gnu/packages/crates-io.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

      "This package provides a speedy, non-cryptographic hash used in rustc.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-rustc-hash-2
+  (package
+    (name "rust-rustc-hash")
+    (version "2.0.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "rustc-hash" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "0lni0lf846bzrf3jvci6jaf4142n1mdqxvcpczk5ch9pfgyk8c2q"))))
+    (build-system cargo-build-system)
+    (arguments `(#:skip-build? #t))
+    (home-page "https://github.com/rust-lang/rustc-hash")
+    (synopsis "Speedy, non-cryptographic hash used in rustc")
+    (description
+     "This package provides a speedy, non-cryptographic hash used in rustc.")
+    (license (list license:asl2.0 license:expat))))
+
 (define-public rust-rustc-hex-2
   (package
     (name "rust-rustc-hex")

base-commit: e3b52240386ce8000494e46981abfd07a03c53b4
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e70fb90401..899f557f57 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -45,6 +45,7 @@ 
 ;;; Copyright © 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
 ;;; Copyright © 2024 Nguyễn Gia Phong <mcsinyx@disroot.org>
 ;;; Copyright © 2024 Jordan Moore <lockbox@struct.foo>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -67554,6 +67555,27 @@  (define-public rust-rustc-hash-1