diff mbox series

[bug#74264] add python-pyet

Message ID 20241108171808.584587-1-ikbenrickhuyzer@gmail.com
State New
Headers show
Series [bug#74264] add python-pyet | expand

Commit Message

Rick Huijzer Nov. 8, 2024, 5:17 p.m. UTC
Change-Id: Ia2be23aeb83911aa93869f82cf0667da8af509c4
---
 gnu/packages/python-science.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)


base-commit: 2a6d96425eea57dc6dd48a2bec16743046e32e06
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index f38992a1c2..f55ec8cac5 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -26,6 +26,7 @@ 
 ;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2024 Marco Baggio <marco.baggio@mdc-berlin.de>
 ;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2024 Rick Huijzer <ikbenrickhuyzer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3576,6 +3577,34 @@  (define-public python-pynsee
 compagnies.")
     (license license:expat)))
 
+(define-public python-pyet
+  (package
+    (name "python-pyet")
+    (version "1.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pyet" version))
+       (sha256
+        (base32 "1dblsx0bv1g453hcx5vwij1zgankwgwvhwllqkn47k578h038xvy"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases #~(modify-phases %standard-phases
+                   (replace 'check
+                     (lambda* (#:key tests? #:allow-other-keys)
+                       (when tests?
+                         (invoke "nosetests")))))))
+
+    (propagated-inputs (list python-pandas python-xarray))
+    (native-inputs (list python-mock python-nose))
+    (home-page "https://github.com/pyet-org/pyet")
+    (synopsis "Python package for evapotranspiration calculation")
+    (description
+     "This package provides a Python library for calculating Evapotranspiration
+    using various standard methods.")
+    (license license:expat)))
+
 (define-public python-libneuroml
   (package
     (name "python-libneuroml")