diff mbox series

[bug#73896,v4,10/20] gnu: Add rust-primal-estimate-0.3.

Message ID 20241105231519.22378-10-ngraves@ngraves.fr
State New
Headers show
Series [bug#73896,v4,01/20] gnu: rust-widestring-0.4: Update to 0.4.3. | expand

Commit Message

Nicolas Graves Nov. 5, 2024, 11:14 p.m. UTC
* gnu/packages/crates-io.scm (rust-primal-estimate-0.3): New variable.
---
 gnu/packages/crates-io.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a025472d5e..eb26506de7 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -56645,6 +56645,28 @@  (define-public rust-primal-check-0.3
      "This package provides a standalone primality testing tool.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-primal-estimate-0.3
+  (package
+    (name "rust-primal-estimate")
+    (version "0.3.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "primal-estimate" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "08nq0n0r35rni65h79fynync0wyy8agrxy5mfmg0hq9s1c510cm4"))))
+    (build-system cargo-build-system)
+    ;; Circular development input rust-primal
+    (arguments
+     `(#:skip-build? #t))
+    (home-page "https://github.com/huonw/primal")
+    (synopsis "Estimate upper and lower bounds for the k-th prime")
+    (description
+     "This package provides a state-of-the-art estimation of upper and lower
+bounds for the number of primes below n and the k-th prime.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-print-bytes-1
   (package
     (name "rust-print-bytes")