@@ -1706,4 +1706,36 @@ (define ghc-hashable-bootstrap-for-9.6
combine hash values.")
(license license:bsd-3)))
+(define ghc-splitmix-bootstrap-for-9.6
+ (package
+ (name "ghc-splitmix-bootstrap")
+ (version "0.1.0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (hackage-uri "splitmix" version))
+ (sha256
+ (base32
+ "00ihw7vji8ydik7f5lk9iwj21j829lpl22wa4nqz2igg26b7mw4x"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "splitmix")))
+ (arguments
+ `(#:tests? #f
+ #:haskell ,ghc-bootstrap-for-9.6))
+ (home-page "http://hackage.haskell.org/package/splitmix")
+ (synopsis "Fast and splittable pseudorandom number generator")
+ (description
+ "This package provides a Pure Haskell implementation of the
+SplitMix pseudorandom number generator. SplitMix is a \"splittable\"
+pseudorandom number generator that is quite fast: 9 64-bit
+arithmetic/logical operations per 64 bits generated. SplitMix is tested
+with two standard statistical test suites (DieHarder and TestU01, this
+implementation only using the former) and it appears to be adequate for
+\"everyday\" use, such as Monte Carlo algorithms and randomized data
+structures where speed is important. In particular, it @strong{should not
+be used for cryptographic or security applications}, because generated
+sequences of pseudorandom values are too predictable (the mixing functions
+are easily inverted, and two successive outputs suffice to reconstruct the
+internal state).")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here
From: Saku Laesvuori <saku@laesvuori.fi> * gnu/packages/haskell.scm (ghc-splitmix-bootstrap-for-9.6): New variable. Change-Id: I65584aa893975015dc44491b120636844af801de --- gnu/packages/haskell.scm | 32 ++++++++++++++++++++++++++++++++ 1 file changed, 32 insertions(+)