@@ -1683,4 +1683,27 @@ (define ghc-clock-bootstrap-for-9.6
timer functions of different operating systems via a unified API.")
(license license:bsd-3)))
+(define ghc-hashable-bootstrap-for-9.6
+ (package
+ (name "ghc-hashable-bootstrap")
+ (version "1.4.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (hackage-uri "hashable" version))
+ (sha256
+ (base32
+ "11sycr73821amdz8g0k8c97igi4z7f9xdvgaxlkxhsp6h310bcz1"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "hashable")))
+ (arguments (list #:tests? #f
+ #:haskell ghc-bootstrap-for-9.6))
+ (home-page "http://github.com/haskell-unordered-containers/hashable")
+ (synopsis "Class for types that can be converted to a hash value")
+ (description
+ "This package defines a class, @code{Hashable}, for types that can be
+converted to a hash value. This class exists for the benefit of hashing-based
+data structures. The package provides instances for basic types and a way to
+combine hash values.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here
From: Saku Laesvuori <saku@laesvuori.fi> * gnu/packages/haskell.scm (ghc-hashable-bootstrap-for-9.6): New variable. Change-Id: Id96f7df459a3db56747cd4204b32b7ad253139a4 --- gnu/packages/haskell.scm | 23 +++++++++++++++++++++++ 1 file changed, 23 insertions(+)