@@ -1638,6 +1638,30 @@ (define ghc-js-flot-bootstrap-for-9.6
requirements of downstream users (e.g. Debian).")
(license license:expat)))
+(define ghc-extra-bootstrap-for-9.6
+ (package
+ (name "ghc-extra-bootstrap")
+ (version "1.7.12")
+ (source (origin
+ (method url-fetch)
+ (uri (hackage-uri "extra" version))
+ (sha256
+ (base32
+ "0g5h8fp0nq4k9asiknw0bhvb10zpfnsixfp0n3xz0rc83pnajwg5"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "extra")))
+ (arguments (list #:tests? #f
+ #:haskell ghc-bootstrap-for-9.6))
+ (inputs (list ghc-clock-bootstrap-for-9.6))
+ (home-page "https://github.com/ndmitchell/extra#readme")
+ (synopsis "Extra Haskell functions")
+ (description
+ "This library provides extra functions for the standard
+Haskell libraries. Most functions are simple additions, filling out missing
+functionality. A few functions are available in later versions of GHC, but
+this package makes them available back to GHC 7.2.")
+ (license license:bsd-3)))
+
(define ghc-clock-bootstrap-for-9.6
(package
(name "ghc-clock-bootstrap")
From: Saku Laesvuori <saku@laesvuori.fi> * gnu/packages/haskell.scm (ghc-extra-bootstrap-for-9.6): New variable. Change-Id: I73f1bd1a821bb01fc9d081c78313e583ce8fab6b --- gnu/packages/haskell.scm | 24 ++++++++++++++++++++++++ 1 file changed, 24 insertions(+)